Google Drive flagging rclone v1.63.1 as unverified app

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Google Drive flagging rclone as unverified app. This is new I've been successfully using rclone for 3+ years.
Rclone and my google drive are working fine however the unverified app causes problems for my android phone because google is putting a security block on it because of rclone.

Run the command 'rclone version' and share the full output of the command.

Are you using the built in oauth credentials?


No, I am not and this has never been a problem before so what has changed?

It's something to to with your oauth credentials I think but I'm not sure what exactly.

Try logging into your Google console and see if there are any messages.

Hi, thanks for replying again. I don't have any messages or errors. I've upgraded versions many times and this has never happened before. I am using the same ...rclone.config settings.

What other steps can I take to troubleshoot and/or resolve? I could delete the config and start over? It's a personal google drive, I pay for 4TB. I only share it with my brother but not using rclone via google share.

Not happy with the security issues this has created for my android phone. Obviously, the phone is more important to me than rclone and security is paramount.

Just to make sure my problem is not misunderstood I've included a photo showing my google apps where rclone is now UNVERIFIED. As I stated this was never a problem before and rclone and my google drive are working flawlessly. The problem is that because rclone is unverified it is causing problems on my android phone because of security concerns by google.

Rclone never had this before a few days ago. Thanks

Log in here

And look under here


And see what you can see.

Hi, I'm not sure what I am looking for but I see no problems.

Look in the credentials section and the OAuth consent screen and see if there are any warnings. Is it set to public the app?

Hi Nick, thanks for all of your help. I've learned things I never wanted to know in this process. Honestly, idk why something changed and I ended up in this situation but nevertheless it is what it is. I know it has something to do with the scopes but I didn't change anything other than upgrade to rclone v1.63.1

I have no warning anywhere. I can't set the app to public because I am not a workspace user. I took the easier route as I am the only user of rclone with my drive. I removed the oath and secret and the (rclone app) is now back to verified.

Again, thanks for your help and I'm sorry I bailed out on trying to find the "scopes not approved" but I have a lot on my place at home, work and life so I just need to move on in the most expeditious manner possible.

Kindly, Dre

Glad you got it working.

Google changes how the oauth stuff every month it seems. It is hard keeping the docs up to date!

I think the public setting would probably fix it, but I'm not sure.

Hey Nick, thanks for the help and your patience.

Take care, Dre

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.