Google Drive error 403:rate limit exceeded when authorizing rclone

What is the problem you are having with rclone?

error 403:rate limit exceeded appears when mounting google shared drive to rclone

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.1

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

There appears to be a problem with abuse of rclone's client ID which Google is cracking down on.

I'm receiving 50 emails an hour from users of sites such as gdtot, mkvcinemas and katmoviehd about this. These sites aren't using rclone, just it's credentials as far as I can make out.

Unfortunately this is affecting genuine rclone users too.

However there is a solution - make your own client ID as outlined in the docs.

It is because Google disabled their Auth Clients due to misuse and that's why they are using Rclone's auth client:


Unfortunately, my university prohibits making any projects in google cloud, so not an option for me. :face_with_diagonal_mouth:

doesn't have to be same google account as your drive. your google cloud can be on one account and drive can be on another

Hi, thanks for responding. Can you give me some detail as to how I can accomplish that? So far I only know how to enable API and create credentials for the account I want to use with rclone, but not for a different account.

Follow this: Google drive

Then when you add a new remote, when the browser opens, login to your drive.

In a nutshell: your cloud console account belongs to a developer with permission to use drive API in his/her apps.

Your drive account belongs to someone who is using an app made by that developer to access drive

Well, I've created my google id, edited all GD remotes, but nothing changed.
Always 403 error

You need to rclone config reconnect yourremote: before the client_id will work.


1 Like

same as me...
Update me if you find any solution.

I had the same error leaving things blank like I used to do.
I followed the guide here Google drive
Everything works fine, authorised and all working. So I guess you need to re-check your setup. If your using a previously added OAuth then dont. Create a new app, new OAuth ID and Secret and you should be good to go.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.