Google Drive Error 400: invalid_request (v1.63.1)

I just got rclone v1.63.1 and when trying to set up an rclone config (for GOOGLE DRIVE) it keeps taking me to the old auth method which rclone (to my knowledge and use) stopped using since January when google retired it. But for some reason it does it when I do it on a headless machine.

This is the output

Verification code

Go to this URL, authenticate then paste the code here.

Which threw me off because I thought google updated to oauth3

`Error 400: invalid_request
The out-of-band (OOB) flow has been blocked in order to keep users secure. Follow the Out-of-Band (OOB) flow migration guide linked in the developer docs below to migrate your app to an alternative method.
Request details: redirect_uri=urn:ietf:wg:oauth:2.0:oob

rclone v1.56.1

  • os/version: debian 11.5 (64 bit)
  • os/kernel: 5.15.107+truenas (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.8
  • go/linking: static
  • go/tags: none

Command: rclone config - then selecting Google Drive, putting client and secret, selecting headless machine.

A log from the command with the -vv flag


Am I missing something or is this a bug

Could you update your rclone to the latest version (v1.63.1)? There is no point in troubleshooting some ancient one.

From your log:

admin@TheSwagShack[...pts/rclone/rclone-v1.63.1-linux-amd64]$ rclone config -vv
2023/08/04 22:29:06 DEBUG : rclone: Version "v1.56.1" starting with parameters ["rclone" "config" "-vv"]
2023/08/04 22:29:06 DEBUG : Using config file from "/home/admin/.config/rclone/rclone.conf"

You downloaded v1.63.1 but you still run old v1.56.1

I guess you have your OS not well maintained repo version installed. The best way to be up to date is:

$ sudo apt remove rclone
$ sudo -v ; curl | sudo bash

and in the future to update:

sudo rclone selfupdate --stable

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.