Google drive created data metadata missing again

Hey there folks. I got this issue resolved before here: Obsidian .md created date missing when using rclone?

I created a file right after and the metadata was correct.

Today, I tried to create a new file from Obsidian in the mount dir again, and it seems to have regressed.

The version is up-to-date.

➜ rclone version
rclone v1.65.0

  • os/version: fedora 39 (64 bit)
  • os/kernel: 6.6.8-200.fc39.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: none

❯ rclone config redacted
type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive =

I'm not sure what could be the cause there. Looking forward to your help yet again. :slight_smile:

Can you provide clear example what the issue is? It is not clear at all what you are doing (including linked post).

Okay, an example was in the previous post. But let me try again.

  • I'm using rclone to sync from Google Drive.

  • I'm mounting the rclone remote using an autostart .desktop file. The .desktop file config is below:

[Desktop Entry]
Exec=sh -c "rclone mount --daemon gdrive: /home/somename/gDrive --vfs-cache-mode full"

  • I use Obsidian to access the notes that are stored in Google Drive. I can access the files pretty nicely.

  • However, when creating a new note in Obsidian, the metadata for the created date is missing. So the date that the note pulls is from 1969. Please refer to the screenshot below to see that the "create" date is simply null.

Here is a test note where the date is default to 1969:

  • In the previous post, it was fixed by updating to the latest version of rclone. But when I tried to create a new note yesterday, the issue happened again. And it's unclear to me why it's happening.
1 Like

Is the created date pulled straight from the file?

If so can you run this (fill in the full path as appropriate) and send the result please?

stat  /home/somename/gDrive/.../

That will get us started in the debug process.

Correct, it gets pulled from the metadata of the file.

I created a new file since I deleted the old.

gDrive/Obsidian Notes/Notes
➜ stat
Size: 81 Blocks: 1 IO Block: 4096 regular file
Device: 0,84 Inode: 15801491792350393281 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 1000/ somename) Gid: ( 1000/ somename)
Context: system_u:object_r:fusefs_t:s0
Access: 2024-01-05 10:14:45.052000000 -0500
Modify: 2024-01-05 10:14:45.052000000 -0500
Change: 2024-01-05 10:14:45.052000000 -0500
Birth: -

That is the problem.

I don't think FUSE supports creation/birth times. Birth times are a relatively new feature on Linux and not all file systems support them.

Oh no. Well, it was strange that it worked for a bit after the update.

Guess I'll have to find a workaround for this then. Thanks for the help on this :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.