Google Drive couldn't read info about Drive 401 Unauthorized

Is there any reason why my Google Drive remote would not work on server (CentOS) reboot but work prior to reboot ?

rclone lsd gdrive1:
2016/10/29 22:05:26 Failed to create file system for "gdrive1:": couldn't read info about Drive: Get oauth2: cannot fetch token: 401 Unauthorized
Response: {
  "error" : "unauthorized_client"

i setup Google Drive remote = gdrive1 without client_id and secret first then later added the client_id and secret and it works up until i reboot my server ?

You shouldn’t set client_id or client_secret unless you’ve registered a google drive app yourself so the config file .rclone.conf should look like this.

client_id = 
client_secret = 

If you did register a drive application then you’ll need to reconfigure from scratch.

i started without client_id but then added it via edit remote to add it and it worked until i rebooted server then it didn’t work

so deleted the remote and re-added it with client_id and it worked so guess that should be the proper way to do it :slight_smile:

1 Like