Google Drive Auth Code

What is the problem you are having with rclone?

Authentication error 401

Run the command 'rclone version' and share the full output of the command.

1.59

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
--> Yes

Which cloud storage system are you using? (eg Google Drive)

Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Not sure here - VFS mount to google drive -has worked forever.

Paste command here

The rclone config contents with secrets removed.

Paste config here
```[gdrive]
type = drive
client_id = xxxx
client_secret = xxx
scope = drive
token = {"xxx":">
team_drive =

Here is my issue.First it started with 403 errors but I have now reinstalled and have a new error. I go through rclone config and all looks well. I get to the final part where I authorize on my local machine with browser. That auth code looks like AAAA for example. But in the rclone.config it doesn't match there - it's BBBB as an example.

Should they look different ? Is it like a public/private key thing? Either case when I run journalctl -xe it's all 401 auth errors from google and saying not authorized maybe token expired.

Are you following the guide here? Remote Setup

The Auth code is now base64 encoded to make it easier to cut and paste.

Are you using the same rclone version on both ends?

Thanks Nick. I did use that method (1). Copy and pasted auth code to headless. Both machines on 1.59.

Even when I delete rclone.conf and redo it . The auth code in there doesn’t look like the one I pasted. Is that supposed to be the case ?

I also noticed on my one box that still works - after token line there is one more line called drive folder ID or something . I’m at work now and going off memory. The one with issue is missing this line

The auth code just lets you get a token.

The token is refreshed every hour so you'll see the rclone.conf change.

Ok that makes sense. Any idea why I’m running into 401 unauthorized errors then ?

Would need to a see a log file with the output.