Google Drive and SAMBA\CIFS

Good morning to everyone.
I am using RClone since years to sync my 12 TB local file server ( based on Ubuntu ) with Google Drive to preserve my data in case of a NAS failure. I have encryption enabled.
I am running out of space on the file server and instead of buying additional disk, I am planning to delete several TB from the file server rerely used and leverage only in Google Drive.
To continue to have such files available with the SAMBA\CIFS, I would like to mount read\write the remote Google Drive on the Linux box and export with CIFS\SAMBA this mounted remote.
Most of the files are movies, pictures and music

Now the question:
can you suggest best practices to do that?


Would do exactly what you think.

rclone mount then use samba to share that mount.

for mount good example look at:

I had my remote on GDrive working exported with CIFS.
I am performing some tests...
With caching disabled, copying data do the CIFS share shows a performance that is more or less 200 Mbps that is my upload speed to the internet
With caching enebled, the copy is performed at light speed, but when the copy is almost completed ( 99% ) than I have to wait a lot to get it to 100%
Let me explian: if the copy without caching takes 1 minute... enabling the cache it takes some seconds to reach 99%, then again 1 minute to go to 100%

Is it correct?

Might be worth looking into details. Do the test and post all info as per Help and Support template.

Got it, but... what I mentioned is the correct behaviour or not?

Just updated the Rclone binaries to the latest version.
I had the problem with fuse3, since I am running Ubuntu 18 that does not officially supports fuse3, so I bypassed with a symlink and... now the behaviour is correct.

Anyway... I run out of space on my local disk. Searching the reason... it was the cache that growed until the disk full.
I run the mount with the option --cache-db-purge, but the local cache is still there with hundreds big files.

What is the correct and official way to completely delete the local cache?

If you post your remotes config (remove all secrets) and mount command + DEBUG logfile - hopefully somebody will be able to figure it out.

It is impossible to help without concrete data - however eloquent is description of your issue. The best way is just provide what template asks for.

rclone mount bck_gsuite:discoA /media/discoA/XXXXXX --allow-other --vfs-cache-mode full

Config File
type = crypt
remote = gsuite:crypt_bck
filename_encryption = standard
directory_name_encryption = true
password = ----------------------------------------
password2 =

type = drive
client_id = ---------------------------------
client_secret = -------------------
service_account_file =
token = {"access_token":"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"}

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.