Google Drive Access blocked: Authorization Error

What is the problem you are having with rclone?

I tried to configure a new Google Drive remote using the instructions on the rclone website. I created a new client ID and client secret using the instructions in Google drive, and entered them in the rclone config. But when I got to the "Use web browser to automatically authenticate rclone with remote?" step, the browser page that opened showed the following error:

Access blocked: Authorization Error
The OAuth client was not found.
If you are a developer of this app, see error details.
Error 401: invalid_client

In this thread with the same problem, the poster said that he was originally using Firefox but then it worked on Chrome. I also started on Firefox, but then tried it on Chrome and it still didn't work.

For what it's worth (probably not much!), I used to use rclone with Google Drive regularly, up until 1-2 years ago, on a different computer (also Linux). I was probably using the default rclone client ID, though.

Run the command 'rclone version' and share the full output of the command.

$ rclone --version
rclone v1.62.2
- os/version: debian bookworm/sid (64 bit)
- os/kernel: 6.2.6-76060206-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: none

I installed rclone a few days ago.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

I was not able to complete the rclone config step.

A log from the command with the -vv flag

I was not able to complete the rclone config step.

Are you entering / creating your own client ID and secret?

Yes. I followed the instructions at Google drive (thanks for such detailed instructions, BTW!)

The error means you are putting in something wrong which is tough as they keys and secrets.

Are you using your own GSuite account / EDU / Personal?

I'm using my personal google account. Everything went fine during the process to obtain the client id. At the end of the steps, it warned me that verification was required, giving a list of the verification steps or options:


Following your instructions at the end of Google drive, I ignored this. But now I'm noticing that under "Verification status", it says "Need verification", and when I click on the "Prepare for verification" button, I see these required fields under App domain:


I don't have an Application home page or privacy policy link; I'm just trying to sync my files.

I setup my personal account quite some time back for testing. I didn't fill anything out and pushed to production:


Thanks for all your help. I'll see what else I can do.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.