Google Drive 24h ban: How do I avoid this?

Hi there,

I managed to mount my encrypted storage under /mnt/media and files can be read by local file system. Plex worked for some time but now I am getting the following error.

Plex Tuner Serv[1792]: Plex Tuner Service: Critical: libusb_init failed

I mount with the following command.

/usr/sbin/rclone mount --uid=1000 --gid=1000 --config=/home/plex/.config/rclone/rclone.conf --read-only --buffer-size=500M --max-read-ahead=500m --acd-templink-threshold=0 --timeout=5s --contimeout=5s --stats=1m --default-permissions --allow-non-empty --allow-other gdrivecrypt: /mnt/media/

And ideas what that is?

Kind regards


The tuner service is running per default on recent plex server versions. Since you seem to have not TV-tuner hardware installed, it simple fails.

This is no issue. Everyone gets this message. You must have some other problem.

Besides, I think this something you should ask in plex forums.

best regards,

Hi Philip,

my money is still on rclone. Now I found following error which points to the rclone mount.

Exception analyzing media file '/mnt/media/Movies/the-file.mkv' (Could not parse /mnt/media/Movies/the-file.mkv (error=-5): Input/output error

Copying in Linux to local disk fails as well.

cp /mnt/media/Movies/the-file.mkv .
cp: error reading ‘/mnt/media/Movies/the-file.mkv’: Input/output error
cp: failed to extend ‘./the-file.mkv’: Input/output error

I used rclone move again to re-upload the file but I get same result.

cp /mnt/media/Movies/the-file.mkv .
cp: error reading ‘/mnt/media/Movies/the-file.mkv’: Input/output error
cp: failed to extend ‘./the-file.mkv’: Input/output error

What I am now using for mounting is the following command.

/usr/sbin/rclone mount --config /home/plex/.config/rclone/rclone.conf --allow-other --read-only --default-permissions --uid 1000 --gid 1000 --umask 002 --acd-templink-threshold 0 --buffer-size 100M --timeout 5s --contimeout 5s --syslog --stats 1m -v gdrivecrypt: /mnt/media/

The log shows that the file transferred with 0 errors, however I’m confused about the bytes numbers.

                                          Transferred:      0 Bytes (0 Bytes/s)
                                          Errors:                 0
                                          Checks:                 0
                                          Transferred:            0
                                          Elapsed time:      6m1.9s
                                           * Movies/the-file.mkv

OK it seems I know what it is: Google Drive web site tells me that some kind of limit for downloading this file has been reached when I try to download the file. How do I avoid situations like this? Is this the 24 hour ban I was reading about? How do I avoid this?

I’m reading at that people had this problem in the past. Is this fixed inside rclone itself? Do I have to use something else to mount the drive or do I have to use some other parameters for the mount or for the copy?

Can I use plexdrive to solve my headache? Can I somehow mount the encrypted data with it? Can plexdrive decrypt it?

Now the thread at Plans to resolve Google Drive 403? seems to be golden. I’ll retry with --tpslimit 5.

Just to document it for myself: You can mount encrypted files with plexdrive, letting plexdrive deal with Google API requests and then let rclone mount (and therefore decrypt) the files locally. Unencrypted files are then accessible from Plex. rclone does nothing with the Google API in this scenario. I’m surprised how badly this was “documented”, I nearly googled myself to death.

Kind regards