Google Cloud Sign-in Limit Rate

What is the problem you are having with rclone?

Cannot login to GCS with the Rclone auth link provided. GCS reports an Authorization Error and asks the developer to increase the sign-in limit. I can't work out if this is an issue at my end or the devs end. I've checked my API Auth rate limits and they are at 70,000 with 0 attempts. Can anyone shed some light on this?

Access blocked: Authorization Error

This app has reached its sign-in rate limit for now.

Google limits how quickly an app can get new users. You can try signing in again later or ask the developer ( to increase this app's sign-in rate limit.

If you are the developer for this app, you can request a sign-in rate limit increase.
Learn more about this error
If you are a developer of this app, see error details.
Error 403: rate_limit_exceeded

Error 403: rate_limit_exceeded
Request details: access_type=offline response_type=code redirect_uri= scope=

Run the command 'rclone version' and share the full output of the command.


Which cloud storage system are you using? (eg Google Drive)

Google Cloud Storage

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone authorize gcs

The rclone config contents with secrets removed.

type = google cloud storage
project_number = XXXXXXX
object_acl = private
bucket_acl = private
token = {"access_token":"XXXXXXX","token_type":"Bearer","refresh_token":"XXXXXXX","expiry":"2022-03-14T15:37:26.670046757+11:00"}

A log from the command with the -vv flag

2022/12/14 10:41:33 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "-vv" "authorize" "gcs"]
2022/12/14 10:41:33 DEBUG : **temp-fs**: config in: state="", result=""
2022/12/14 10:41:33 DEBUG : Using config file from "/home/.config/rclone/rclone.conf"
2022/12/14 10:41:33 DEBUG : OAuth only is set - overriding return state
2022/12/14 10:41:33 DEBUG : **temp-fs**: config out: out=&{State:*oauth,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
2022/12/14 10:41:33 DEBUG : **temp-fs**: config in: state="*oauth,,,", result=""
2022/12/14 10:41:33 DEBUG : **temp-fs**: config out: out=&{State:*oauth-confirm,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
2022/12/14 10:41:33 DEBUG : **temp-fs**: config in: state="*oauth-confirm,,,", result=""
2022/12/14 10:41:33 DEBUG : Auto confirm is set, choosing default "true" for state "*oauth-islocal,,,", override by setting config parameter "config_is_local"
2022/12/14 10:41:33 DEBUG : **temp-fs**: config out: out=&{State:*oauth-islocal,,, Option:<nil> OAuth:<nil> Error: Result:true}, err=<nil>
2022/12/14 10:41:33 DEBUG : **temp-fs**: config in: state="*oauth-islocal,,,", result="true"
2022/12/14 10:41:33 DEBUG : **temp-fs**: config out: out=&{State:*oauth-do,,, Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
2022/12/14 10:41:33 DEBUG : **temp-fs**: config in: state="*oauth-do,,,", result=""
2022/12/14 10:41:33 DEBUG : Starting auth server on
2022/12/14 10:41:33 NOTICE: If your browser doesn't open automatically go to the following link:
2022/12/14 10:41:33 NOTICE: Log in and authorize rclone for access
2022/12/14 10:41:33 NOTICE: Waiting for code...
2022/12/14 10:41:47 DEBUG : Redirecting browser to:

Can you retry with the latest version?

Hi Animosity022 thanks for the reply. I've just updated and tried again. No success with the exact same issue.

Update info below.

rclone v1.60.1
- os/version: debian 10.13 (64 bit)
- os/kernel: 4.19.0-22-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.3
- go/linking: static
- go/tags: none

I would try making your own client ID and secret.

Unfortunately there have been many side projects stealing rclone key and abusing it.

Thanks. Just to be clear you are suggesting creating a OAuth client id in Google Console?

If so, how can I then use this to authorise Rclone. I can't see any cmds or flags that let me input a client id + secret?

Yes, I'd imagine you can follow the drive page for how to.

Looks like from the docs, you can just enter it in:

as the pic has it there.

I'm not sure as I've never used GCS.

Oh of course, just rerun the config. I was looking under the rclone authorize cmd. Cheers I'll see if this fixes it.

Yep. This fixed the issue, thanks.

Steps to resolve if any has a similar issues.

  1. Login to Google Cloud Console
  2. Select organisation + project
  3. Under APIs & Services choose Credentials
  4. Create a credential and choose OAuth Client ID
  5. Application Type: Desktop Application
  6. Name: Rclone or whatever you want to specify
  7. Run rclone config and if existing backend then hit e to edit
  8. Input client id + secret when prompted
  9. Follow usual steps to authenticate via the browser.

Yeah, it's a bummer we can't fix it easily without breaking other folks but that's sadly the world we live in.

At least the fix isn't to troublesome and affects GCS rather than all backends.

Thanks for your assistance, much appreciated.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.