Getting error message when trying to use a rclone remote KeepassXC file

Hi all,

I am trying to use a keepass file (kdbx file) that this hosted on a cloud storage provided by Hetzner. This storage provides several different accesses (webdav, ssh, sftp, scp, samba).
I succeeded in mounting the file and opened it in my app KeepassXC. The file can be used with some latency but it is totally acceptable.

What is the problem you are having with rclone?

Getting an error message in KeepassXC when trying to save a modification to the Keepass file.
Error message I get is:

Writing the database failed: Destination file exists.
Backup database located at ....

What is your rclone version (output from rclone version)

rclone v1.55.1
- os/type: linux
- os/arch: amd64
- go/version: go1.16.3
- go/linking: static
- go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Unraid  6.9.2
Linux ket 5.10.28-Unraid #1 SMP Wed Apr 7 08:23:18 PDT 2021 x86_64 Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz GenuineIntel GNU/Linux

Which cloud storage system are you using? (eg Google Drive)

Hetzner StorageBox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount kp_ssh: /mnt/user/Cloud/keepass --config $CONFIG_FILE \
--allow-other \
--dir-cache-time 60s \
--poll-interval 5s \
--log-level INFO \
--umask 002 \
--user-agent cartacherandom \
--cache-dir=$CACHE_DRIVE \
--vfs-cache-mode full \

I tried the different vfs-cache-mode (off, write full).
I tried different protocols (webdav, ssh, sftp).
It is important to note that mounting the drive in windows as a webdav mount works.

Is there a means to make it work or do I have to use the webdav windows mount.
Thank you for your support.

rclone-mount-keepass.log (73.6 KB)

so for the debug log snippet, what was the exact rclone command?

trying to understand your use-case
do you have multiple version of keepass running on multiple machines, all accessing the kdbx at the same time or just the one winbox?

There was no rclone command as such that triggered the write. The file located on the mount point was written due to a change in the KeepassXC app.

So to summarize:

  • I mount a remote storage on the unraid server mount point
  • I share the mount point on my lan
  • I open the kdbx file located on the share in the KeepassXC app
  • I am able to read the kdbx entries
  • When I try to create a new or update an entry in the file, the error is triggered and the log extract is the one copied.

I am accessing the remote keepass db from my iphone and other client.



for that debug log snippet, what was the exact rclone mount command?
best to post the full debug log instead of just a snippet.

and you did not post the config file?

for what it is worth, i am heavily dependent on keepass and tend to be very paranoid about it.
your setup seems too complex to me, using rclone mount on unraid, sharing that mount over a lan to a winbox.
if webdav works reliably, then i would use that.


I removed the snippets and uploaded a log of the full scenario.

To answer your question, if the way I planned to use it is to complex, I will use the local webdav option.

But it would be interesting to understand why I am getting this error.



there was no error in the rclone log.
i have no idea about that keepass error, perhaps the keepass forum could help.

imho, you have a overly complex setup used in a way keepass was not designed for.

the problem could be unraid config problem, sharing a rclone mount over a lan, windows config problem, cloud storage config problem.

I agree with you about the complexity of the setup.
Though have a similar setup, even with an additional layer, for accessing gdrive data and it is working quite smoothly.
Unraid Mergerfs
Unraid Share
Rclone Mount
Google Drive

Thank you again for your help.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.