Getting a 500 error when trying to create a Google Drive config from the GUI running in a Docker container and it doesn't open auth window

What is the problem you are having with rclone?

I am running rclone gui from a Docker container. I can browse configs fine. I am trying to add one for Google Drive and I am getting a 500 error. It creates the config but never finishes the creation process. It should open a new window so I can auth the Google Drive but it never opens that window.

Run the command 'rclone version' and share the full output of the command.

/data # rclone version
rclone v1.58.0
- os/version: alpine 3.15.1 (64 bit)
- os/kernel: 5.10.28-Unraid (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.18
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

n/a - using GUI

The rclone config contents with secrets removed.

it is empty

A log from the command with the -vv flag

Error creating config. Error: Request failed with status code 500

Screenshots

Creating a new config:

Before clicking Next

Error after clicking Next

Console error after clicking Next

image

Config was created but never finished -- it didn't open a new window to auth:

@ncw Hi. I am sorry to tag you like this but do you have any idea what could be wrong? I opened an issue in GitHub but no traction their either.

Through the CLI I know the code opens a browser to finish the config auth. It works the same if you add config through the GUI. But if you have rclone running in a Docker container then it won't open the 2nd step auth window.

I tried to find the relevant part of the code but no luck....

I don't use dockers but if you want to create a config elsewhere or run headless, that's probably an easier option.

It's nothing rclone related per se as the docker part obfuscates a lot of things and oAauth flows require localhost access properly or it will not work well.

It's not that it doesn't open a 2nd auth window as rclone wants to open a browser window and that is something you can't do as you are contained in a docker. You'd have to install a browser in your container an expose that somehow which is well beyond me.

It doesn't get much traction here as it's not really a rclone question but a docker question.

It is a Docker thing but it is specific to how rclone implemented auth. I've been looking at the code and I see what is wrong. I just can't find the relevant parts in in the rclone source for how to fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.