Gdrive - shared drive (ex gsuite) and shared folder problem

What is the problem you are having with rclone?

hi, i have a problem, in my gdrive account i have a shared gsuite drive (not mine, unlimited) and a shared folder (unlimited too). Currently to see both, I had to use 2 cmd instances of rclone, the one for the shared folder I douto set "shared with me" to be able to see it.
Is there a way to see them both with one CMD instance?
Also, when I copy files to the shared folder, the size of the files cannot exceed the quota of my gdrive account (2gb), so I am forced to copy one file at a time which do not exceed the quota ...
Is there any way around this?

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: windows/amd64
  • go version: go1.15.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win 10 64

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here
rclone mount teamdrive:/ Z: --vfs-cache-mode writes

rclone mount "gdrive:/BACKUP ANIME by IL SAGGIO" Y: --vfs-cache-mode writes

#### The rclone config contents with secrets removed.  
<!--  You should use 3 backticks to begin and end your paste to make it readable.   -->

Paste config here

#### A log from the command with the `-vv` flag  
<!-- You should use 3 backticks to begin and end your paste to make it readable.  Or use a service such as or   -->

Paste log here

You can always do a union remote and combine them.

not sure exactly what you mean, that you want to use run one command instead of two commands?

let's say yes, I mean that I had to create 2 remote instincts, one for the shared folder and one for the shared drive, consequently I have to open 2 separate CMD screens as if they were different, while they belong to the same account as me..
moreover, as written, in the case of the remote created for the shared folder, I cannot copy files larger than the space left in my account, that is 2gb, while in reality the folder where I try to copy has unlimited space..
using UNION would I see, in the resource explorer, only one drive? with both the folder and the drive inside? because to see the unlimited shared folder, I had to use "shared me" while I had to remove the option to see the unlimited shared drive, otherwise it didn't work

what is the problem with using two mounts and copying between them?

actually there are no problems opening 2 CMDs, it was just to find out if there was a way ... the problem is to copy files larger than the remaining amount available on my 15gb account, because instead of copying all the file in bulk, I have to copy one file at a time

? :sweat_smile:

trying to understand....
to move one file at a time from a gdrive account to another gdrive account?

if true, then why not
rclone sync teamdrive: "gdrive:/BACKUP ANIME by IL SAGGIO" --transfers=1 --drive-server-side-across-configs

I don't know ... with this syntax exactly what would I do? Would I move everything in the shared folder directly to the team shared drive? bypassing the quota limit of my private account?

gdrive has lots of quotas, which quota?

teamdrive is the destination?

both the shared folder and the shared drive have unlimited space, but once the drives are mounted, if I copy files to the shared folder, he sees the space in my google account as remaining space, the remaining 15gb standard, that is 2gb .. so if I try to copy a larger file it tells me space is out, while if I copy many smaller files it makes me load them
shared folder is destination

what is not a quota, but a limit

what is wrong with this?
rclone sync teamdrive: "gdrive:/BACKUP ANIME by IL SAGGIO" --transfers=1 --drive-server-side-across-configs --max-size=2G

gdrive accounts are free, so why not create a new one and be able to transfer files up to 15GB

no, because both the shared folder and the shared drive are shared with my google account, the one that has 2gb of remaining space

about that command, why would that not work?

with the mounts,
have you tried adding --drive-server-side-across-configs to get about that 2GB limit?

i haven't tried, but so i don't set the limit to 2GB instead of removing it?

ok with "rclone copy onedrive: teamdrive: --transfers=1 --drive-server-side-across-configs"
i'm transferring everything from onedrive to treamdrive ... definitely a silly question ... isn't there a way to not switch from my pc being limited by my bandwidth?

There's no magic to server side from one provider to another as they are different providers so you cannot.

Server side is used when you are moving within the same provider if they support it.

in fact I said it was a silly question ... I tried :sweat_smile:

Not silly at all!

I never feel silly asking something I don't know as that's the only way to confirm things.

Always ask as that's how learn.

Thanks ... as soon as I finished copying everything I will surely have other questions to ask ... however I realized that to use rclone it was necessary to install winfsp