Gdrive crypt mount freezes but not non-crypt

Newbie here so sorry and thank you in advance.

Need some help, i'm using rclone with gdrive (business) with 2 mounts. 1 crypt and the other not.

I'm using windows 10 and the mount that is encrypted keeps having issues with disconnecting. I haven't timed it but it happens after leaving it alone for a day.

If I try to click on the encrypted mount drive, it will freeze/crash my system. Cannot even restart without manually powering off. The odd thing is that the non-crypt mount works with seemingly no issues.

I could not figure out how to get a log file but here is my info:

rclone version v1.52.1
windows 10 x64
using my own google client id

rclone config:
type = drive
client_id =
client_secret = ###mypwd###
scope = drive
token = ###mytoken###
root_folder_id = ####

type = crypt
remote = gdrive:/backup
filename_encryption = standard
directory_name_encryption = true
password = pwd1
password2 = pwd2

######### rclonemount ("gdrive" x:) #########
mount --allow-other --dir-cache-time 72h --drive-chunk-size 64M --cache-dir T:\x_rclone-tmp-x --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off gdrive:/ X: --config "C:\Users\htpc.config\rclone\rclone.conf" --vfs-cache-mode writes

######### crypt-drive ("crypt" p:) #########
mount --allow-other --dir-cache-time 72h --drive-chunk-size 64M --cache-dir T:\x_rclone-tmp-p --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off crypt:/ P: --config "C:\Users\htpc.config\rclone\rclone.conf" --vfs-cache-mode writes

hello and welcome to the forum,

  • you are duplicating vfs flags between two mounts and using two different cache-dir folders.
    i never saw anybody doing that.
    the computer might be running out of ram.
    i would remove the flags from one of the mounts, to not 100% sure from which mount.
    tho i would remove the flags from gdrive: and test.

  • please update to latest stable, v1.53.0 - there are been some major improvements to the vfs cache.

  • --allow-other does nothing on windows.

  • what version of winfsp are you running?

  • there is a big difference between freezing and crashing. can you describe in more detail?

  • about the log - you can add this to the mount command
    --log-level=DEBUG --log-file=C:\Users\htpc.config\rclone\rclone-p.txt

Thanks for the reply.

Per your recommendation, i've updated rclone and winfsp (i was running 1.4? i think) to the latest.
I also completely removed my "gdrive x" mount to test. Had some issues getting crypt to remount, keep getting service_paused but it seems to be up and running now. I've also enabled logging, will wait for crash and send log.

If it ends up working for more than a few days, will also post update.

thank you again.

So it's been about 6 days and everything seems to be running without any major issues. When i first switched to above and was transferring a large amount of files, it did lock my windows for a few minutes but nothing like before. Before, i would have to reboot my system.

I ended up changed the log-level from debug to error only. Debug made a 5gb+ that i couldn't open.

The only error the log file show is "vfs cache: failed to _ensure cache EOF" which from my understanding isn't really an issue and will be addressed in the next release (or using beta now).

If i did want to add another mount that was not encrypted, what would the proper settings be?

Thank you again.

glad to hear the mount crypt remote is working.
can you post the command?

That will be addressed in v1.53.1 which I'll release tomorrow if I have time.

1 Like

used this for the crypt:

mount --dir-cache-time 72h --drive-chunk-size 64M --cache-dir T:\x_rclone-tmp-p --log-level=DEBUG --log-file=T:\x_rclone-log\rclone-p.txt --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off crypt:/ P: --config "C:\Users\htpc.config\rclone\rclone.conf" --vfs-cache-mode writes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.