GD + Crypt + Mount

Hi all.

I have done some googling etc. but I haven’t seen anything around this question. Should I be able to write to a GD + Crypt mount?
Mounting it works fine and I can read from the mount easily and it stays mounted. If I try to write to the mount via command line rsync it “works” but after sometime the mount fails and stops working. This is fine if writing isn’t supported yet. :slight_smile:

To be perfectly honest I’m not sure whether this works well or not! I’ve been concentrating on getting the reading working 100% - for writing stuff I’d reccomend using rclone directly (not using a fuse mount) as it is much better at doing the retries necessary.

Note that writes don’t support seek so you should use the --whole-file option in rsync. I’d recommend using rclone directly rather than using rsync + rclone mount.

As for it stops working - have you got a log of that happening? Run the mount with --log-file rclone-mount.log -v --debug-fuse and see what it says!

Thank you very much for your work on rclone. For now ‘rclone sync’ is working perfectly, its just the writing directly to the mount that causes things to fail. Happy to try it again with the logging options provided earlier and will report back then.

Ok so I ran a test with the mount options specified and the rsync options mentioned as well. It did write some data, about 350MB but then fell over. Hopefully the log helps you somewhat.

Thanks for the log. I don’t see what went wrong though. When you said rclone fell over what happened? There are no unexpected errors in the log.

Well thats a shame. The rsync stops and complains about missing the file/directory. I say it falls over because I have run the mount command again if I want to try another copy.
I just ran the mount command, transferred a 2MB and it transferred without error but if I run an ‘ls’ on the mount nothing is there. Sorry that what I am providing is not helping.

I did a quick test to try to replicate this but I didn’t succeed yet.

Can you provide a sequence of commands for me to try which replicates the problem for you? I can then try them here and debug the problem further.