FTP backend: SetModTime: 550 Not enough privileges

What is the problem you are having with rclone?

SetModTime: 550 Not enough privileges.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0
- os/version: debian 10.11 (64 bit)
- os/kernel: 4.19.0-18-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /tmp/rclone-v1.57.0-linux-amd64.deb ArubaFTP:video-colloqui-storico  -vvv

The rclone config contents with secrets removed.

[ArubaFTP]
type = ftp
host = ftp-r1-it.storage.cloud.it
user = ddl-nc-colloqui
pass = abcde

A log from the command with the -vv flag

# rclone copy /tmp/rclone-v1.57.0-linux-amd64.deb ArubaFTP:video-colloqui-storico  -vvv
2022/01/12 13:53:38 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "copy" "/tmp/rclone-v1.57.0-linux-amd64.deb" "A
rubaFTP:video-colloqui-storico" "-vvv"]
2022/01/12 13:53:38 DEBUG : Creating backend with remote "/tmp/rclone-v1.57.0-linux-amd64.deb"
2022/01/12 13:53:38 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2022/01/12 13:53:38 DEBUG : fs cache: adding new entry for parent of "/tmp/rclone-v1.57.0-linux-amd64.deb", "/tmp"
2022/01/12 13:53:38 DEBUG : Creating backend with remote "ArubaFTP:video-colloqui-storico"
2022/01/12 13:53:38 DEBUG : ftp://ftp-r1-it.storage.cloud.it:21/video-colloqui-storico: Connecting to FTP server
2022/01/12 13:53:40 DEBUG : rclone-v1.57.0-linux-amd64.deb: Need to transfer - File not found at Destination
2022/01/12 13:53:46 ERROR : rclone-v1.57.0-linux-amd64.deb: Failed to copy: SetModTime: 550 Not enough privileges.
2022/01/12 13:53:46 ERROR : Attempt 1/3 failed with 1 errors and: SetModTime: 550 Not enough privileges.
2022/01/12 13:53:46 DEBUG : rclone-v1.57.0-linux-amd64.deb: Need to transfer - File not found at Destination
2022/01/12 13:53:53 ERROR : rclone-v1.57.0-linux-amd64.deb: Failed to copy: SetModTime: 550 Not enough privileges.
2022/01/12 13:53:53 ERROR : Attempt 2/3 failed with 1 errors and: SetModTime: 550 Not enough privileges.
2022/01/12 13:53:53 DEBUG : rclone-v1.57.0-linux-amd64.deb: Need to transfer - File not found at Destination
2022/01/12 13:54:00 ERROR : rclone-v1.57.0-linux-amd64.deb: Failed to copy: SetModTime: 550 Not enough privileges.
2022/01/12 13:54:00 ERROR : Attempt 3/3 failed with 1 errors and: SetModTime: 550 Not enough privileges.
2022/01/12 13:54:00 INFO  :
Transferred:       41.800 MiB / 41.800 MiB, 100%, 2.155 MiB/s, ETA 0s
Errors:                 1 (retrying may help)
Elapsed time:        21.6s

2022/01/12 13:54:00 DEBUG : 3 go routines active
2022/01/12 13:54:00 Failed to copy: SetModTime: 550 Not enough privileges.

The crappy FTP server they gave me (the logs doesn't say the name) isn't supporting modtime change. Can I still use it with rclone? I didn't find a switch to turn off modtime set on FTP, just for SFTP.
I tried set_modtime = false (still from SFTP) but same output.

If can be of any help rclone backend features ArubaFTP: shows:

{
        "Name": "ArubaFTP",
        "Root": "",
        "String": "ftp://ftp-r1-it.storage.cloud.it:21",
        "Precision": 1000000000,
        "Hashes": [],
        "Features": {
                "About": false,
                "BucketBased": false,
                "BucketBasedRootOK": false,
                "CanHaveEmptyDirectories": true,
                "CaseInsensitive": false,
                "ChangeNotify": false,
                "CleanUp": false,
                "Command": false,
                "Copy": false,
                "DirCacheFlush": false,
                "DirMove": true,
                "Disconnect": false,
                "DuplicateFiles": false,
                "GetTier": false,
                "IsLocal": false,
                "ListR": false,
                "MergeDirs": false,
                "Move": true,
                "OpenWriterAt": false,
                "PublicLink": false,
                "Purge": false,
                "PutStream": true,
                "PutUnchecked": false,
                "ReadMimeType": false,
                "ServerSideAcrossConfigs": false,
                "SetTier": false,
                "SetWrapper": false,
                "Shutdown": true,
                "SlowHash": false,
                "SlowModTime": false,
                "UnWrap": false,
                "UserInfo": false,
                "WrapFs": false,
                "WriteMimeType": false
        }
}

thanks

I'm not aware of a flag that turns off modtime for FTP as that's for SFTP.

hi,

not sure this will work but might try no-update-modtime

I tried that, but same result.

That means if you have a file that's already there, it won't update the modtime. The first transfer wants to set the modtime.

Pure guesswork, but perhaps --use-server-modtime will do the trick.

https://rclone.org/docs/#use-server-modtime

Same as well.

Crappy provider (Aruba.it) offering FTP access to their crappy S3-like-wannabe object storage. I managed to find a saint who shared S3 config for it, now it seems to work. At least it's uploading.

It's also faster than FTP, so I'll give up on this.

Thank you very much everyone for the help!