Folder name contains @

What is the problem you are having with rclone?

Special character in symlink, will not copy (@ character)
error is: ERROR : REDACRED FOLDER: Listing error: symlink: stat REDACRED FOLDER: no such file or directory

the folder structure is like this:
/location/to/symlink/folder@ -> /actual/location/of/file/without-the-@-symbol

how can I make this work, if possible?

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

freebsd 11

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

rclone sync -v $source $dest --copy-links --sftp-set-modtime --progress

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

What's your rclone.conf look like?

Can you run a rclone ls command on the problematic folder and share the debug output with -vv?


type = sftp
host =
user = rw_user
port = 22
pass =
key_file = /root/.ssh/id_rsa
use_insecure_cipher = false
disable_hashcheck = true

(info: I have a ssh config file that has server info)

output of command with -vv

rclone ls -vv /location/to/folder/.hashes/Documents		<-- This folder shows up as Documents@ when doing ls. This is also a symlink to another location
2020/08/22 14:10:54 DEBUG : rclone: Version "v1.42" starting with parameters ["rclone" "ls" "-vv" "/location/to/folder/.hashes/Documents"]
2020/08/22 14:10:54 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2020/08/22 14:10:54 ERROR : : error listing: directory not found
2020/08/22 14:10:54 Failed to ls: directory not found

Edit: I am trying to use rclone to backup data to offsite storage. I am running rclone on the NAS. The NAS is mounted by another server under /media/backup. The Documents@ links to /media/backup/Documents on the server, but the /media/backup/Documents does not exist on the NAS hence rclone will not find the /media/backup/Documents when following the link. Hope this makes sense.

You are using a very old rclone can you try a newer one.

I am using 1.52.3, that's the latest.

Sorry, I did not show the proper version on my initial post.

Edit: I see what you mean. Something is not right. Let me fix that first.

Edit 2: Got rclone upgraded to 1.52.3. Same behaviour and error as with the prev. version, no improvement or changes.

Can you please post the new debug log.

rclone ls -vv /location/to/folder/.hashes/Documents
2020/08/22 21:58:04 DEBUG : rclone: Version "v1.52.3" starting with parameters ["rclone" "ls" "-vv" "/location/to/folder/.hashes/Documents"]
2020/08/22 21:58:04 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2020/08/22 21:58:04 DEBUG : fs cache: renaming cache item "/location/to/folder/.hashes/Documents" to be canonical "/long/path/to/of/location/to/folder/.hashes/Documents"
2020/08/22 21:58:04 ERROR : : error listing: directory not found
2020/08/22 21:58:04 DEBUG : 2 go routines active
2020/08/22 21:58:04 Failed to ls with 2 errors: last error was: directory not found

Can you share an ls -al on the directory that does not list?

Try using the -L flag so rclone follows symlinks - that might help.

Same error with rclone ls FOLDER -L.

Basically, the NAS has folders that have symlinks to a location that does not exist on the NAS, so rclone cannot follow the link and does not copy that folder. I want it to just copy the folder with the symlink info without following the link to the actual location. I also have tried rsync and it works fine and does not throw errors, however, I would prefer to use rlone.

If you don't want to follow the symlink but want to copy it then you want the -l flag. Try listing the directory above the symlink and you'll see what it does.

I did a rclone ls FOLDER -l and did not get any errors. So this looks promising. I will try running a sync and will see what the outcome is. Thanks for that and all the help!!!

While running rsync and rclone sync, I noticed that rclone does not saturate the upload the way rsync does. With rsync (its single threaded) I will saturate my upload (12Mbit/s), but when using rclone, I only get about 8Mbit/s. I am already using --drive-chunk-size 128M, it helps but not much. Any ideas?

did you post your rclone sync command, that includes the actual source and actual dest, not just variables.
all i see is rclone sync -v $source $dest
is the source or dest using gdrive, as --drive-chunk-size 128M is a flag for gdrive

Full command:

rclone sync /source/folder/Backup/ ssh-remote:/target/folder/Backup/ -l --sftp-set-modtime --progress --drive-chunk-size 128M

if you are not using gdrive, then --drive-chunk-size 128M does nothing, so you can remove it.

Try using more or less --transfers

Beautiful! This did the trick, rclone is uploading 50% faster. That almost full saturation of my max upload, better than rsync!

Thank you very much for your help!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.