Finder / dirs with accents / error -43

What is the problem you are having with rclone?

First of all, hello and thanks for trying to help me

I have an issue regarding extended character set and specially characters like "é" in directory names.
This is not a filename issue
This issue only appears using the Finder not command lines

What is your rclone version (output from rclone version)

rclone v1.53.1-DEV

  • os/arch: darwin/amd64
  • go version: go1.15.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS Catalina 10.15.7

Which cloud storage system are you using? (eg Google Drive)

Google Drive with encryption

The command you were trying to run (eg rclone copy /tmp remote:tmp)

make a directory with accents using Finder like "mélanger"
copy any file in that directory gives an error "The operation can't be completed. An unexpected error occurred (error code -43)"

The rclone config contents with secrets removed.

type = drive
scope = drive

type = crypt
remote = mine:/documents
filename_encryption = standard
directory_name_encryption = true

The mount command (maybe should help)

/usr/local/bin/rclone mount \
    --rc-addr \
    --transfers 8 \
    --volname documents \
    --allow-other \
    --log-level INFO \
    --buffer-size 32M \
    --vfs-cache-mode writes \
    --vfs-cache-max-size 16G \
    documents:/ /Volumes/documents

A log from the command with the -vv flag

Note: I don't know how to use cmount on my OS, command doesn't work
2020/10/02 07:41:31 NOTICE: macOS users: please try "rclone cmount" as it will be the default in v1.54
2020/10/02 07:41:31 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
2020/10/02 07:42:31 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
2020/10/02 07:43:31 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)

Thanks in advance for any advices

Try first the new cmount, you just change mount to cmount in your mount command.


/usr/local/bin/rclone cmount \
    --rc-addr \
    --transfers 8 \
    --volname documents \
    --allow-other \
    --log-level INFO \
    --buffer-size 32M \
    --vfs-cache-mode writes \
    --vfs-cache-max-size 16G \
    documents:/ /Volumes/documents

I tried :slight_smile:

Here what I'm getting:

/usr/local/bin/rclone cmount
Error: unknown command "cmount" for "rclone"

Did you mean this?

Run 'rclone --help' for usage.
2020/10/02 09:19:42 Fatal error: unknown command "cmount" for "rclone"

Did you mean this?


Weird, would think it would be in the beta. Try to install the stable version rclone v1.53.1.

~ rclone --version
rclone v1.53.1
- os/arch: darwin/amd64
- go version: go1.15.1

~ rclone cmount
  rclone cmount remote:path /path/to/mountpoint [flags]

I assume you installed it via brew? Those builds don't have the cmount command due to missing build tags. You will need to install rclone again via the steps given here:

Hello, you're perfectly right, I used brew
I've installed the good macos version, thanks for the advice.

By the way, I'm still getting my error -43 while trying to use a directory with accents in its name (with Finder app)

Can you add the debug logs with cmount? Note, you need to add -vv to the mount command to get the DEBUG logs

See if adding -o modules=iconv,from_code=UTF-8,to_code=UTF-8-MAC to the mount command works.

Great, it works with this addons
Won't it slow down accesses using iconv like this?

Not sure. It shouldn't make too much of a difference, however.

Thanks, I need extensive tests as far as I can see, while syncing with uploads, reads are very slooow :slight_smile:

this flag does nothing on a mount
--transfers 8

1 Like

Should that be the default for macOS count do you think?

I understand that to be saying translate the utf-8 from standard to macOS NFD form?

Not sure since I don't mount using rclone on MacOS. According to this comment, the to_code should also probably be skipped if we do add that fuse flag by default:

Once we have a consensus, I can submit a PR (if required) since it's not a big change.

1 Like

I'm using MacOS and French characters
I had to add this in order to be able to create directories with accents and store file in without -43 errors

So I think it's necessary for MacOS

I'd be happy to test!


Can you try substituting -o modules=iconv,from_code=UTF-8 instead of the earlier argument i.e. -o modules=iconv,from_code=UTF-8,to_code=UTF-8-MAC and see if that works?

The to_code should be automatically detected.


Hello, that works perfectly

Great, thanks.

@ncw Do you want me to submit this as a flag (something like --translate-utf-8 ?) in a PR?

Is this flag always needed on macOS to get UTF-8 to behave properly?

Or might you not want it for some reason?

The minimum option would be to add it to the docs (but it will only work for cmount)...