Filtering files occur malformed rule

What is the problem you are having with rclone?

I tried to filter some files to be copied from GDrive folder to locally, those files that starts with 1, followed by 3 digits and ends with .rar (like: 1441.rar, 1021.rar, etc)

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: Microsoft Windows Server 2012 R2 Standard Evaluation (64 bit)
  • os/kernel: 6.3.9600.20337 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.17.9
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

m:\tools\rclone>rclone.exe copy data:folder C:\all --filter 1{{[0-9]{3}}}.rar --progress --transfers 10 --checkers 5

also tried

m:\tools\rclone>rclone.exe copy --filter 1{{[0-9]{3}}}.rar data:folder C:\all  --progress --transfers 10 

same thing

A log from the command with the -vv flag

2022/05/04 01:17:53 Failed to load filters: malformed rule "1{{[0-9]{3}}}.rar"

A filter rule needs to have a leading + or - to say whether it is an include or exclude rule.

I suspect you want --include instead of --filter this should work OK

--include "1{{[0-9]{3}}}.rar"

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.