File stuck in rclone cache (not being uploaded)

I have a file that is in my cache-tmp-upload-path. It’s been there for about 10x longer than my cache-tmp-wait-time. I’ve tried rm from the cache mount and it says it can’t delete because the file is still being uploaded, but I can’t see any network activity from rclone that looks like an upload.

Is there a clean way to rm this file so I can add it back?

Also, does anyone know why this might have happened and how I can mitigate it in the future?

What version are you running?
What are the logs showing?
What’s your configured mount command that you are running?

Sorry, should have provided all of that.


  • rclone v1.40
  • os/arch: linux/amd64
  • go version: go1.10


Apr 24 05:02:28 ubuntu rclone[10568]: cache-cleanup: chunks 40, est. size: 358.623M
Apr 24 05:03:28 ubuntu rclone[10568]: cache-cleanup: chunks 36, est. size: 285.501M
Apr 24 05:04:29 ubuntu rclone[10568]: cache-cleanup: chunks 46, est. size: 375.633M
Apr 24 05:05:29 ubuntu rclone[10568]: cache-cleanup: chunks 49, est. size: 391.355M
Apr 24 05:06:29 ubuntu rclone[10568]: cache-cleanup: chunks 46, est. size: 394.836M
Apr 24 05:07:29 ubuntu rclone[10568]: cache-cleanup: chunks 41, est. size: 349.277M
Apr 24 05:08:29 ubuntu rclone[10568]: cache-cleanup: chunks 7, est. size: 58.646M
Apr 24 08:03:35 ubuntu rclone[10568]: cache-cleanup: chunks 4, est. size: 30.067M
Apr 24 08:23:30 ubuntu rclone[10568]: tvshows/The Office (US)/Season 9/The Office (US) - S09E22 - A.A.R.M Bluray-1080p x264 DTS.mkv: File.Remove file error: tvshows/The Office (US)/Season 9/The Office (US) - S09E22 - A.A.R.M Bluray-1080p x264 DTS.mkv is currently uploading, can't delete
Apr 24 08:28:37 ubuntu rclone[10568]: cache-cleanup: chunks 8, est. size: 70.067M

The last log message was over 4 hours ago. The delete error is from when I manually tried to rm the file. I haven’t done anything since but the file is still there.


/usr/bin/rclone mount gdcache: /mnt/media \
   --allow-other \
   --dir-cache-time=160h \
   --cache-chunk-size=10M \
   --cache-info-age=168h \
   --cache-workers=5 \
   --cache-tmp-upload-path /data/rclone_upload \
   --cache-tmp-wait-time 60m \
   --attr-timeout=1s \
   --syslog \
   --umask 002 \
   --log-level INFO

Cache settings

type = cache
remote = gdrive:
plex_url =
plex_username = <username>
plex_password = *** ENCRYPTED ***
chunk_size = 10M
info_age = 24h
chunk_total_size = 100G
plex_token = <token>

I think you’ll probably have to stop and start rclone.

No… If you can reproduce it reliably then please make a new issue on github with instructions on how to reproduce it.

Thanks @ncw. I’ll get that file removed and try and reduce it to a replicable test case for github.

Do you mean remove the file from my cache-tmp-upload-path? Will I also have to remove it from the cache.db, or will this automatically update?

I’m not 100% sure but I think rclone will either continue the upload after the restart or ignore the file - not sure which without checking that bit of code!

I’ve tried restarting a few times. Each time an rm says it can’t delete because of an upload, despite the fact that after the restart the upload does not start again. My guess is the cache is storing the fact the upload has been started, and so the upload doesn’t start again, nor is it removable.

Tonight I’m going to try the following steps:

  1. stop rclone
  2. remove file from tmp directory
  3. start rclone
  4. copy file to mount directory

Let me know if there’s anything else I should be checking/doing.

I’d probably stop rclone, clear out the tmp upload area, start up rclone, I’d kill -HUP to refresh the cache db. Once that builds up again, resume normal operations as it just sounds like something got caught in the middle of a stop or something along the way.

I’ve checked my tmp area and have nothing area and Sonarr/Radarr do their thing with the partials and removes and such and I have a lot of volume over the days.