File size Limit Sharepoint?


#1

Hi there,

is there currently a limitation to 300MB for Sharepoint?

Any workaround? Is it just the Sharepoint API which s****?

Best
David


#2

I think this is a limit the sharepoint administrator can change, rather than a limitation of sharepoint.


#3

This is weird.

It actually does not upload big files here.

I can upload those files manually through the webUI of sharepoint.

Is there a size limit for webDAV?

Thanks
David


#4

Here is an article about Sharepoint WebDAV file limits.

This states the default limit is 50MB but it is changeable by the admin.


#5

Hi ncw,

thanks for the reply!

We have a sharepoint on sharepoint.com , I guess I can’t change anything there?

Best
David


#6

I don’t know.! Can you ask your (or an) admin?


#7

I will see if I can figure out something. Will let you know!


#8

Ok, so there is a limitation to 250MB in one case:

“250 mb is the hard limit for any list item attachment in SharePoint online.”

Now I am not sure how to upload the files differently in a way that they are not list items…?


#9

I think you are using WebDAV with sharepoint.

You can also use the onedrive backend with sharepoint - maybe you could give that a go and see if that helps?


#10

I tried to set up the onedrive backend. But when it goes to authentication, browser opens on 127.0.0.1 as it should, and leads me to MS:
https://login.live.com/oauth20_authorize.srf
There it says
“That Microsoft account doesn’t exist. Enter a different account or get a new one.”

Weird because this account is active and has a whole office license and everything.


#11

Cut and paste the URL rclone prints out into an incognito window (or whatever your browser calls it). I’ve found in the past that it is easy to get MS accounts mixed up when doing the authorisation and doing it in an incognito windows stops that.


#12

Tried this already, but no change.
The account is definitely an Office account, even tried with some other accounts.

But that’s for sure not an issue of rclone then, right?

Edit: I was not running latest version on my desktop! Seems to work with 1.45 :slight_smile: Will try to configure!


#13

:slight_smile: Graph support is relatively recent and you’d need that for sharepoint.


#14

This might now be the problem…


#15

Can you mount one of the folders as in this comment?


#16

Hi ncw,

I tried but am not able to get any request working. Trial and error form the page source with siteID and webID…

“error”: {
“code”: “InvalidAuthenticationToken”,
“message”: “Access token is empty.”,

Does not work…

At the moment it might just work fine with webDAV as long as we don’t need to upload big files.
Those will be uploaded manually then.

I will keep rclone up2date and also try to re-configure it from time to time.


#17

:frowning: It might be worth asking for help on that issue as people who know more about it than me may be able to help you.


#18

Hi ncw,

thanks. I will see if I get some more info somewhere.
Anyway it is not urgent.
If marketing ever notices they miss a file I’ll ask them to upload those few big files manually :stuck_out_tongue: