File getting lost on mounted GDrive

Hello all,

I lately updated from rclone 1.50 to 1.51 but had some issues with IOWAIT and therefore went with to the latest beta on that time (v1.51.0-076-g38a4d50e-beta).

Unfortunately, I just noticed that some file get lost when I move them within the mount using WinSCP.
From what I've seen so far only bigger files seem to be affected.

Here is a log from the time frame I moved a file and it got lost:

Ubuntu 18.04.4 LTS
Kernel: 4.15.0-88-generic
Mount: mount --allow-non-empty --allow-other --dir-cache-time 8760h --poll-interval 0 --vfs-cache-mode writes --vfs-cache-max-age 0m --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 2G --drive-use-trash=false --log-level DEBUG --log-file /opt/rclone/rclone.log upload: /mountpoint

Anyone else experiencing or an idea what could be happening here?
Thank you!

Can you give an example of a file before and after it was moved?

You can run a rclone ls against the remote to see the file before and check where you expect to be after you move it.

It's best to use the question template as that asks for a few things to help out as I am not sure what backend are you using since the whole log isn't there so it's a bit tough to guess as you have some commands in there that seem odd for the mount (depending on the backend).

I did some further research and after rebooting my system it seems to be solved.
Already tried a couple of versions of rclone (1.48, 1.50.2, latest beta) and the issue hasn't been reproducable until now.

Seems like something in the background was causing some trouble and the reboot solved it.
So, false alarm, sorry guys!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.