Feil 400: admin_policy_enforced

What is the problem you are having with rclone?

I’m new to rclone and trying to configure the rclone but I got the error when I was asked to log in to my google account. The error message is as follows.

Feil 400: admin_policy_enforced 
Access to your account data is restricted by policies within your organization. 
Please contact administrator for more information.

I’m using my private google account to create a project on Google Cloud Platform and the google account that is connected with google drive is from my University (G Suite).

I thought it was something to do with the setting from university side, but they told me that my account should work with the default setting they have for all the students and that previous students managed to use rclone with their G Suite account.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: centos 7.9.2009 (64 bit)

  • os/kernel: 3.10.0-1160.6.1.el7.x86_64 (x86_64)

  • os/type: linux

  • os/arch: amd64

  • go/version: go1.17.2

  • go/linking: static

  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

I’m guessing I can not fill out here as I haven’t configured yet.

A log from the command with the -vv flag

Same as above

Are you sure you used the right account to make the initial config with Google drive? I would have thought you would need to use your university account rather than your private account.


Thanks for the answer.
I read Google drive and it says

  1. Log into the Google API Console with your Google account. It doesn't matter what Google account you use. (It need not be the same account as the Google Drive you want to access)

so I thought I can use my private account.
It needs more procedure and some paper work for me to create a project in GCP with my university account so that’s also why I want t avoid using uni account for the first procedure.

Your school doesn't allow it, hence the error.

It's possible unless the administrator blocks it.

Creating the project with your personal account it is fine.

It is when you do the rclone config that you need to use the university account I think.

Thanks again.

Yes, at the end of configuration, I used my university google account to log in but the error appeared.

Because they've blocked access..

I contaced the IT desk but they said they did not and the current setting should allow me to use:(

You have the error directly in your logs:

That means it is blocked regardless of what they are saying as that is the policy they have configured.

Okay, thank you. I’ll contact them again !

Be very specific as you have a an account not in the domain trying to use Drive API access which looks to be blocked based on the admin policies.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.