Feedback on web-gui

Ah, ok, at least that's how I get the login screen. The username is indeed: GUI but what is the password?

The password is whatever you set it to via the parameters:

OK, again a step further, but now the hint appears:

Of course, I have repeatedly pressed the login button

edit: I'm obviously too stupid today: you have to first press the verify and THEN the login button.

Thanks for your great help.

It's not super obvious to hit verify than login so it's a vey valid question :slight_smile:

When you know the answer, any question seems silly so no worries at and happy it is working!

I ran rclone rcd --web-gui in RClone 1.50 and got

  rclone rcd <path to files to serve>* [flags]

  -h, --help   help for rcd

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.

2019/10/26 10:22:17 Fatal error: unknown flag: --web-gui

If I just run rclone rcd I get

2019/10/26 10:23:22 Failed to start remote control: start server failed: listen tcp bind: address already in use

What I am doing wrong?

That should be

rclone rcd --rc-web-gui

That means you are already running an rclone with the --rc parameter or an rclone rcd.

Strange that return no page at my browser.

Depending on how rclone was started it may not show a page there. What message did the browser show?

Just try-try until timeout (I am using Firefox 70 60bit on Ubuntu 16.04).

See if you can see another rclone running. Try ps ax | grep rclone if running on linux, or look in the process manager on windows.

Yes, running:
ps ax | grep rclone return:

5463 pts/17   Tl     0:00 rclone rcd
9757 pts/17   S+     0:00 grep --color=auto rclone

I killed this process ran rclone rcd again and now the browser is returning Not found text message for the ip/port.

I did. Killing the process and re-running rclone rcd --rc-web-gui.

Is it working now?

Yes, perfect now.

After the first use, at the second, the browser start to ask by user and password to access the page started by rclone rcd --rc-web-gui command. I didn't define any. What should I use?

If you don't define any you need to keep the browser window open as username and password get auto generated and passed in.

Otherwise start with

rclone rcd --rc-web-gui --rc-user me --rc-pass password

I am not sure if this is relevant to this issue, but there was a weird bug I struggled with for a long time that made launching the web-UI act very weird...

Basically, only the rcd currently takes initiative to download the webUI files (which end up in the --cache-dir next to the VFS). Without these files you get weird crashing and 404's, and I was trying to launch it with only --rc-web-gui on a mount.

Since you've tried to use rcd from the start it probably isn't the same issue, but I'd advise just do a quick check that there does in fact exist a "webgui" folder in the relevant cache dir. I suppose if you don't specify any cache-dir in your rcd command then the default location would be used...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.