Fedora Silverblue -- cannot update rclone --> use toolbox to install with rclone script

What is the problem you are having with rclone?

I want to use rclone on Fedora Silverblue to mount a proton drive. I first installed v.1.64.2 but, after starting rclone config, could not find proton drive as an option in the displayed list of storage options.

So I tried updating, but nothing works: I tried downloading v.1.65, 1.66 and even 1.67 beta (as rpm) but whenever I open them, the software windows tells me it's version 1.64.2. And if I do install, rclone version confirms that I have 1.64.2.

Uninstalling has no effect: when I uninstall, rclone is gone, but when I download a new rpm to re-install, the software window tells me it's v.1.64.2.

Run the command 'rclone version' and share the full output of the command.

rclone 1.64.2

  • os/version: fedora 40 (64 bit)
  • os/kernel: 6.8.4-300.fc40.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Proton drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)


Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.


A log from the command that you were trying to run with the -vv flag


You can use the script provided on rclone.org to let rclone install itself, it will install the latest version. Then you can use rclone selfupdate to let it update itself (no rpm).

Thanks @dinosm, but that doesn't seem to work on Silverblue. /Usr/bin is read-only.

I think that's the whole point of that OS as everything is identical.

It probably ships with a dated version. You'd probably want to check on their forums to specifically see if / how to update a package as from my skimming, it doesn't seem super obvious.

Sorry if that's a stupid question because I'm new to all this, but isn't a flatpak version available? Seems like that would make it independent of what's provided by Fedora.

From my quick search, changing to a flatpack breaks the whole point of Silverblue.

What's the reason you picked an immutable OS like Silverblue over something like just Fedora or something else?

But specifically, no flatpack version that I'm aware of. Few posts about it, but rclone is a single binary at the end of the day. It's one of the easier things generally to install barring an immutable OS like Silverblue.

Damn. I wanted to try because it seemed more stable to start with (although that does admittedly come with downsides).

But, from what I get, it's the opposite:

Flatpak apps: this is the primary way that (GUI) apps get installed on Fedora Silverblue. (fedora.org)

Flatpaks allow something to be just dropped neatly on top of the distro which does not need to be changed.

At any rate, the packages that I find on github do get installed. I just don't get why they all give me version 1.64.2. Maybe something got broken at some point?

Distro maintainers can package whatever version they wish. For something like rclone, you'd want to avoid a distro version and use what you want. That can be done via the OS packages that are available or generally via the install script on all of the regular OS flavors out there.

Debian for example is built on stability and it's package is mega old.
Ubuntu is more current and it has later versions but still behind.
Fedora tends to be more bleeding edge so it 'generally' has a current version.

Distro maintainers are not affliated with rclone so they can do whatever they deem correct for their OS as they decide what is the 'proper' version for their OS.

Any of the popular OS flavors are very stable as you'd want to pick one that generally meets your needs.

My take on them generally goes from stability to bleeding edge so something like:

Debian / RedHat -> Ubuntu / Fedora

It depends on what you want to do. If you need more current packages, perhaps Ubuntu/Fedora. If you want tried and true stability, use Debian/Redhat/CentOS or something along those lines.

Thanks for the input, this is useful.

Back to rclone, I found a way-around using toolbox. So, for those in the same situation: create a toolbox (toolbox create, toolbox enter) and then you can use the rclone script. You may need to install fuse.

It's not really working at the moment because it doesn't seem to actually mount the remote, but that's another issue, so we can close this one.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.