Feature request: --no-update-modtime gives error when modtime is updated

Dear Rclone devs,

First, thanks for the great work, with a useful and flexible tool, readable documentation and a user forum :slight_smile:

Here I suggest that when a user (e.g. me) uses Rclone sync --no-update-modtime [...] that Rclone gives an error when that modtime is updated anyway. I think Rclone is quite vocal (rightfully so!) in other places, so I feel this would -maybe dusty- corner of Rclone's functionality may be overlooked until now.

So here is my maybe-overly-careful command to sync a file to another folder (note that using rclone copy gives the same result):

$ rclone sync --check-first --verbose --no-update-modtime --metadata --checksum my_file.txt swestore:/snic/snic2020-4-19/

2024/04/02 10:08:03 INFO  : my_file.txt
2024/04/02 10:08:03 INFO  : 
Transferred:   	        210 B / 210 B, 100%, 0 B/s, ETA -
Transferred:            1 / 1, 100%
Elapsed time:         0.4s

When I doublecheck, the source has a modification time in the year 2021:

$ stat my_file.txt
  File: my_file.txt
  Size: 210       	Blocks: 8          IO Block: 1048576 regular file
Device: 56h/86d	Inode: 8245        Links: 1
Access: (0755/-rwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2024-04-02 07:15:38.253158200 +0200
Modify: 2021-09-30 12:23:12.630070500 +0200
Change: 2021-09-30 12:23:12.630070500 +0200
 Birth: 2021-09-30 10:31:21.691291300 +0200

However, when I check the file at the destination, I get different times:

$ stat my_file.txt
  File: my_file.txt
  Size: 210       	Blocks: 1          IO Block: 4096   regular file
Device: 40h/64d	Inode: 10          Links: 1
Access: (0700/-rwx------)  Uid: ( 1000/  richel)   Gid: ( 1000/  richel)
Access: 2024-04-02 09:36:55.000000000 +0200
Modify: 2024-04-02 09:36:55.000000000 +0200
Change: 2024-04-02 09:36:55.000000000 +0200
 Birth: -

I expected that at least 'Modify' would be identical for the file at both locations. Maybe I make a false assumption here and it is reasonable that 'Modify' is different between the two locations.

I would desire, however, to get an error message to state my assumption is wrong. Or a flag that makes Rclone even more vocal. Or the --verbose flag to state something went wrong.

Would you agree it would be a good idea to make Rclone more vocal on when timestamps are updated against the will of the user?

Thanks and cheers, Richel Bilderbeek

welcome to the forum,

well, you used --no-update-modtime , so rclone does not change the dest modtime to be equal to source modtime.
tho might have something to do with --checksum

can you re-create the issue by copying a single file and then post the full debug output.
and please post

  • rclone version
  • rclone config redacted

rclone copy --dry-run --vv
rclone check

for displaying modtime, use rclone lsl, not stat

That was the problem indeed! I misunderstood the documentation of --no-update-modtime ! Removing that flag solves the problem.

Thanks @asdffdsa! I will mark this question as solved :+1:

Hmmm, I cannot mark this post 'Solved', I assume it has to do with a too low reputation. Maybe in the future :slight_smile:

1 Like

Might be because you posted this in the Feature Request category instead of the Help and Support category. I don't know if you can mark a feature request as solved.