Fatal error: failed to mount FUSE


Impossible to mount drive with 1.54.0

Follow the commands:

PS C:\> C:\rclone-v1.53.4-windows-amd64\rclone.exe mount drive: C:\gdrive `
>> --drive-stop-on-upload-limit `
>> --drive-acknowledge-abuse `
>> --cache-dir="V:\z" `
>> --buffer-size=256M `
>> --vfs-cache-mode=full `
>> --stats=1m `
>> --stats-log-level=DEBUG
The service rclone has been started.
The service rclone has been stopped.

PS C:\> C:\rclone-v1.54.0-windows-amd64\rclone.exe mount drive: C:\gdrive `
>> --drive-stop-on-upload-limit `
>> --drive-acknowledge-abuse `
>> --cache-dir="V:\z" `
>> --buffer-size=256M `
>> --vfs-cache-mode=full `
>> --stats=1m `
>> --stats-log-level=DEBUG
2021/02/06 13:11:12 Fatal error: failed to mount FUSE fs: mountpoint directory is at root: C:\
PS C:\>

You need to install WinSFP:

Check for how to mount as well on Windows as that is documented there too.


i think that winfsp is installed, as that error would be different

i would try:

  • change the current working directory to be something other then c:\
  • make sure that the mountpoint folder does not exist.
  • run the command with debug output, add -vv and post that output.

If WinFSP was not installed i could not not mount drive with 1.53.4 version

That's kind of why we have the help template that you deleted all the pieces too as we have only bits of a picture so we have to guess things.

If you can hit all the pieces in the template, it makes the process much easier.

I'm having the exact same issue, here's all my content:

Fatal error: failed to mount FUSE fs: mountpoint directory is at root: Z:\

rclone mount Freydrive: Z:\Freydrive --vfs-cache-mode full --no-modtime --fast-list -vv --log-file=rclone.log

Where Freydrive: is a remote teamshare GDrive (however this issue also occurs with a SFTP remote so seems indiscriminate of remote type).
This error also occurs when doing a plain rclone mount Freydrive: Z:\Freydrive so the other flags don't seem to affect it.

The directory Z:\Freydrive does not exist, in fact the entire Z: mountpoint is nonexistent when running the command.
However, if I tried for example C:\Freydrive (where the Freydrive folder does not exist, but the C:\ drive does exist), the same error occurs.

I'm using the latest stable rclone - version v1.54.0, os windows/amd64, go1.15.7
The latest WinFSP is installed - version 1.8.20304.
My config is encrypted so I don't believe I can post it, but it just includes 2x GDrive teamdrive remotes (one of which is Freydrive), both using my own client_id/secret, and 1x SFTP remote. The error occurs with all of them. Other operations seem to work on them; I can list the root dir of the teamdrives without issue.
The full log file is as follows: https://pastebin.com/DxCMJZ46

Any help would be greatly appreciated!

Try this instead

rclone mount Freydrive: Z:

Does that work?

I think when you give it Z:\ it it is trying to mount it on the root directory of Z: rather than as Z:

@albertony - do you think we should detect the use of Z:\ and just change it to Z: ?

The docs say this

When mounting as a fixed disk drive you can either mount to an unused drive letter, or to a path - which must be non-existent subdirectory of an existing parent directory or drive

When I try it I can't mount a directory on the root of C: so C:\potato but I can mount C:\mnt\potato where I created C:\mnt first.

So maybe the docs need clarifying here? Or maybe there is a bug..

I always mounted with C:\gdrive and always worked, just stopped working with the error when using 1.54.0

I have thought about it...

Don't remember atm, if there was a good reason why I left it commented out. Perhaps was just afraid it would break somewhere I had not tested it properly. But anyway, seems the real issue is something else:

Must think...

Edit: Didn't notice at first @ncw mentioning the docs section:

The following examples will mount to an automatically assigned drive, to specific drive letter X: , to path C:\path\to\nonexistent\directory (which must be non-existent subdirectory of an existing parent directory or drive

So yes, mounting "C:\potato" is not legal according to this. But then I'm surprised it was possible before. I see the old docs said more or less the same:

Or on Windows like this where + "X:" + is an unused drive letter
or use a path to non-existent directory.
rclone + commandName + remote:path/to/files X:
rclone + commandName + remote:path/to/files C:\path\to\nonexistent\directory

So then what @klunky says means the docs were wrong before also: it did in reality not have to be non-existent.

Thanks for the answer !

So, in your opinion there's anything i can do to make c:\gdrive work with 1.54.0 ?

Did a quick test with rclone v1.53.3 to compare:

Mounting to root dir on existant drive works:

rclone mount remote: C:\Mnt

Mounting to dir on non-existant drive does not work:

rclone mount remote: Z:\Mnt
Cannot create WinFsp-FUSE file system: invalid mount point.
2021/02/08 13:34:40 ERROR : jottacloud root '': Mount failed
2021/02/08 13:34:40 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

No. To get this to work we need to change code and release a new version, unfortunately!


I will see if i can get a pull request to fix this case quite soon.

But I think the following one is not supposed to work, and did not before 1.54, when Z: does not exist:

Thanks for your efforts !

If I can do anything on my side let me know

A fix is on the way:

Testing a beta build if/when @ncw merges the fix to master would be great.

1 Like

Let me know when it's available :slight_smile:

Using Win 8.1 x64

I've merged @albertony's fix to master now which means it will be in the latest beta in 15-30 mins

Please test :slight_smile:

(I should have merged it to a branch really, but I'm living dangerously today :wink:


Working :slight_smile:

PS C:\> C:\rclone-v1.55.0-beta.5166.cc5a1e90d-windows-amd64\rclone.exe mount drive: C:\gdrive `
>> --drive-stop-on-upload-limit `
>> --drive-acknowledge-abuse `
>> --cache-dir="V:\z" `
>> --buffer-size=512M `
>> --vfs-cache-mode=full `
>> --stats=1m `
>> --stats-log-level=DEBUG
1 Like

Thanks once again @albertony and @ncw

1 Like

Thanks for your amazing work on this guys! Is there any way to mount to a dir on a non-existent drive though? I was hoping to mount multiple remotes under different folders on the same non-existent drive (Z:). Would there be any way to do this?

i have a small 1GB volume as the b: drive, then i have multiple mounts to that.
rclone mount b:\mounts\remote1 remote1:
rclone mount b:\mounts\remote2 remote2:

That is not possible, you would have to use a workaround such as the one described above. The WinFsp library rclone on Windows is based on uses Windows mechanisms DefineDosDevice for drive mounting and NTFS reparse points (of type directory junction) for mounting on a directory path, and neither of them allow this.