Failed to open a cache connection

Hello Guys,

I am trying to configure rclone mount as per this url:

when i try to run this command
rclone mount gcache: ~/mnt/gdrive --allow-other --cache-db-purge --allow-non-empty --buffer-size 64M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

I am getting following error.

ERROR : /home/plex/.cache/rclone/cache-backend/gcache.db: Error opening storage cache. Is there another rclone running on the same remote? failed to open a cache connection to "/home/plex/.cache/rclone/cache-backend/gcache.db": timeout
2019/11/20 14:58:21 Failed to create file system for "gcache:": failed to start cache db: failed to open a cache connection to "/home/plex/.cache/rclone/cache-backend/gcache.db": timeout

my rclone config looks like this atm:

I need help!!!!!!!!!!

That error means you already have a cache rclone running as it only allows one to be running at a time.

You'd want to kill the existing process and only run a single rclone cache process.

Hi, I have tried using 'kill' but still it is not working. Can I change my rclone conf file to make it work or is there any command that i can run? thanks

You need to find the process and terminate the running one. There isn't a way to 'config' around that.

ps -ef | grep rclone

kill the processes that are already running.

okay and i am getting this when i run your given command

root      2339     1  0 14:17 ?        00:00:00 sudo rclone mount gcache: /home/                                                                                        plex/mnt/gdrive --allow-other --cache-db-purge --allow-non-empty --buffer-size 6                                                                                        4M --dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode min                                                                                        imal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G
root      2340  2339  0 14:17 ?        00:00:00 rclone mount gcache: /home/plex/                                                                                        mnt/gdrive --allow-other --cache-db-purge --allow-non-empty --buffer-size 64M --                                                                                        dir-cache-time 72h --drive-chunk-size 16M --timeout 1h --vfs-cache-mode minimal                                                                                         --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G
plex      3021  2581  0 15:11 pts/1    00:00:00 grep --color=auto rclone

What command i can use now?

kill 2339

would be the process you want to kill.

thanks it worked. now when i run mount command it returns nothing so i think it worked. thank you so much :slight_smile:

Usually this problem happens when people try to run more than 1 remote on the same cache (and concurrent access is not possible so it has to be handled otherwise).

Since you are not trying to do this then it just sounds like a mount got stuck and did not dismount correctly, which is not so uncommon when you test stuff.

kill will work, but you can also just try to force-unmount to clear it if this happens:

# Linux
fusermount -u /path/to/local/mount
# OS X
umount /path/to/local/mount

It should generally not occur under normal operation, but if there are abnormal terminations Linux does not just pull the plug on the underlying mounts like Windows does, so it is worth being aware of.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.