Failed to lsd: directory not found

What is the problem you are having with rclone?

Immediately after setting up new remote, getting directory not found errors. I go through the config steps as described on the Google drive page, including the browser portion, and afterward the remote is listed when I run

rclone listremotes



But I keep getting "directory not found" errors when I try to run the command.

What is your rclone version (output from rclone version)

rclone v1.45

  • os/arch: linux/amd64
  • go version: go1.11.6

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian GNU/Linux 10 (buster)
64-bit architecture

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd remote

The rclone config contents with secrets removed.

In the paste below I've replaced the token strings with XXX

type = drive
scope = drive
token = {"access_token":"XXXXX","token_type":"Bearer","refresh_token":"XXX","expiry":"2020-12-29T18:53:39.694911933-05:00"}

A log from the command with the -vv flag

2020/12/29 19:36:07 DEBUG : rclone: Version "v1.45" starting with parameters ["rclone" "-vv" "lsd" "remote"]
2020/12/29 19:36:07 DEBUG : Using config file from "/home/athorn/.config/rclone/rclone.conf"
2020/12/29 19:36:07 ERROR : : error listing: directory not found
2020/12/29 19:36:07 Failed to lsd: directory not found

Super old version so you want to update.

You want to use:

rclone lsd remote:

The : needs to be after the remote name.

Thanks. I'm running the version that is included in the Debian packages.

You don’t want to use that version as it’s years old.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.