Failed to ls with 2 errors: last error was: remote error: tls: user canceled

What is the problem you are having with rclone?

Hi, i have problem when ls ftp folders, thanks for help me

What is your rclone version (output from rclone version)

rclone v1.54.0-beta.4770.f8436468a.fix-ftp-PRET

  • os/arch: windows/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows

Which cloud storage system are you using? (eg Google Drive)

FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls will:

The rclone config contents with secrets removed.

[will]
type = ftp
host = ftp.server.com
user = USER
port = 2121
pass = *** ENCRYPTED ***
explicit_tls = true
concurrency = 1
no_check_certificate = true

A log from the command with the -vv flag

2021/01/01 11:39:08 DEBUG : rclone: Version "v1.54.0-beta.4770.f8436468a.fix-ftp-PRET" starting with parameters ["rclone" "ls" "will:" "-vv"]
2021/01/01 11:39:08 DEBUG : Using config file from "C:\\Users\\user\\.config\\rclone\\rclone.conf"
2021/01/01 11:39:08 DEBUG : Creating backend with remote "will:"
2021/01/01 11:39:08 DEBUG : ftp://ftp.server.com:2121: Connecting to FTP server
2021/01/01 11:39:09 ERROR : : error listing: remote error: tls: user canceled
2021/01/01 11:39:09 DEBUG : 2 go routines active
2021/01/01 11:39:09 Failed to ls with 2 errors: last error was: remote error: tls: user canceled

Strange! user canceled is a tls error

From the docs

This handshake is being canceled for some reason unrelated to a protocol failure. If the user cancels an operation after the handshake is complete, just closing the connection by sending a close_notify is more appropriate. This alert should be followed by a close_notify. This message is generally a warning.

So not much clearer!

Can I suggest you try with the latest beta rather than the fix-ftp-PRET branch since support for that is now merged.

Hi, thank you very much for your reply, I tried the latest beta and unfortunately the same error message appears. How can I solve 'thank you very much

I really don't know what that error message means. The only hit on Google is this page!

Have you got a firewall you can disable? Or other local networking stuff - eg a proxy - which is interfering?

I have nothing about it, also because always in the same local network accessing with another ftp client, it works, only with rclone this error appears. Thanks

Can you try making this number bigger?

Sure, how can I do? So I try now and let you know

1 Like