Failed to create file system for "remote:xxxxx"

What is the problem you are having with rclone?

I am trying to mount google drive. The mounting works fine with the 'rclone-browser', but fails via command line with the error:
Failed to create file system for "remote:DriveRemote": didn't find section in config file
I even tried to list the files using ls or lsd, both terminate with the same error.

What is your rclone version (output from rclone version)

rclone v1.56.2
- os/version: arch 21.1.6 (64 bit)
- os/kernel: 5.14.10-1-MANJARO (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.1
- go/linking: dynamic
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount remote:DriveRemote /home/Documents/drivemount
rclone ls remote:DriveRemote

The rclone config contents with secrets removed.

type = drive
client_id = Redacted
client_secret = Redacted
scope = drive
token = {Redacted}

A log from the command with the -vv flag

rclone lsd remote:DriveRemote -vv                                                                                                                                                                                         
2021/11/11 15:30:40 DEBUG : rclone: Version "v1.56.2" starting with parameters ["rclone" "lsd" "remote:DriveRemote" "-vv"]
2021/11/11 15:30:40 DEBUG : Creating backend with remote "remote:DriveRemote"
2021/11/11 15:30:40 DEBUG : Using config file from "/home/user/.config/rclone/rclone.conf"
2021/11/11 15:30:40 Failed to create file system for "remote:DriveRemote": didn't find section in config file

PLEASE NOTE: The mount works fine with the rclone-browser!
And it with -vv flag, it does show the correct location of the config file!

I just don't seem to understand what is wrong.

That file doesn't contain your config is what the error is telling you. Are you using the same user? When you check the file are the contents there?

That’s what. I have the config exactly at that location and the contents are as shown in the post.

also, if the rclone-browser is able to mount it, wouldn’t it be using the same config?

I don't use rclone browser so I'd have no idea as that's a 3rd party thing.

From the same prompt, please share:

felix@gemini:~$ rclone config file
Configuration file is stored at:
felix@gemini:~$ rclone config dump

For the dump, please make sure to remove any passwords/keys/etc.

Here it is:

rclone config file                                                                                                                                                         
Configuration file is stored at:
rclone config dump                                                                                                                                                         
    "DriveRemote": {
        "client_id": "REDACTED",
        "client_secret": "REDACTED",
        "scope": "drive",
        "token": "{\"access_token\":\"REDACTED",\"expiry\":\"2021-11-11T15:58:52.561564578+05:30\"}",
        "type": "drive"

Oh jeez.

Sorry as I completely missed something super easy.

Should be:

rclone lsd remote:DriveRemote:

The remotes need a ":" at the end of them.

Doesn't work. Same error. :frowning:

Failed to create file system for "remote:DriveRemote:": didn't find section in config file

Gr. Sorry as I'm not wake yet either.

rclone lsd DriveRemote:

The remote name is just that, the name of the remote in your config file with a colon at the end of it.

Damn! Yes. This works.
TBH, I had tried this earlier as well when I wa randomly trying out cobinations lol. THNKS!!!!

No worries at all. Sorry it took that long to get there as sometimes the super obvious things are the hardest to see!

Yes, happens all the time :slight_smile:
No need for a sorry :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.