Fail to create config directory on Synology for B2

What is the problem you are having with rclone?

I run rclone on a Synology device, and need to reinstall rclone after a DSM update. rClone was removed for some reason. When setting up the config file, I receive the following error message:

Failed to save config after 10 tries: failed to create config directory: mkdir /var/services/homes: file exists

When I try to look in /var/services/homes, I get:

No such file or directory

It appears to be a sym link:

lrwxrwxrwx 1 root root 24 Jan 22 2016 homes -> /volume1/@fake_home_link

Is this a typical location for the config file?
Any ideas what the problem may be?
Thank you

What is your rclone version (output from rclone version)

rclone v1.52.2

  • os/arch: linux/arm
  • go version: go1.14.4

Which cloud storage system are you using? (eg Google Drive)

B2

hello,

to find the config file
rclone config flie

as for the default location.
https://rclone.org/docs/#config-config-file

Thank you,

rclone config file

gives the following output:

Configuration file doesn't exist, but rclone will use this path:
/var/services/homes/*user*/.rclone.conf

In Volume1/ where the sym link points to, there is a file called .@fake_home_link.swo with permissions -rw-------

Still not sure why the origianl error says file exists

when creating the config file, you can specify its location like so.

rclone config --config=./rclone.conf

Thanks for helping out.

I tried to make the config file in usr/local/bin like so:

rclone config --config=/usr/local/bin/rclone.conf

But get the following message:
NOTICE: Config file "/usr/local/bin/rclone.conf" not found - using defaults

I can continue on with the config setup, but at the end throws another error:
Failed to save config after 10 tries: Failed to create temp file for new config: open /usr/local/bin/rclone.conf347424308: permission denied

permissions for /bin are drwxr-xr-x

-Thanks

you need to use sudo to create a file in that folder, so not a good location for a config file.

try
rclone config --config=./rclone.conf

@fake_home_link.swo
this is a synology thing, you can google it

Thank you about the hint for @fake_home_link. Turns out I needed to turn on user home service in synology user settings. I have everything up and running proper now.

Thanks a ton!

glad to hear that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.