Execute Rclone Sync Without Config File

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

I'm syncing files from local to AWS s3 using Rclone. Can rclone execute sync without creating config file ? I mean by passing aws accesskey, secret key etc as part of the body ?

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: Microsoft Windows 10 Enterprise 21H2 (64 bit)
  • os/kernel: 10.0.19044.2846 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

yes, via the command line, can use connection strings and/or environment variables.

did you try? did that not work? is there a rclone debug log?

Hi navdeep,

Perhaps you are looking for something like this:


Not tested and not sure if everything is correctly escaped/put in quotes - but hope you get the idea.

More info here:

1 Like

@Ole @asdffdsa :
Tried the following

But getting this error:
(removed image with secrets - ncw)

could be an issue with formatting, need to use quotes for values

Tried even that, but same error.

I guess the error message is caused by the (newline?) character just before region=

PS: Your IAM access key and secret are visible in the error message, I therefore recommend you immediately delete the access key used above and make a new.

Yes, that worked. Thank you !!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.