Excutable from rclone mount unable to run as admin

What is the problem you are having with rclone?

Unable to run execuatble on rclone mount as asdmintrator

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.1

  • os/version: Microsoft Windows 10 Enterprise Dev (64 bit)
  • os/kernel: 10.0.21354.1 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.18.5
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount Yandex: * --vfs-cache-mode full --file-perms 0777 --dir-perms 0777 --config=%windir%\rclone.conf -vv --log-file=%windir%\Logs\rcloneYandex.log

The rclone config contents with secrets removed.

rclone config without secrets

A log from the command with the -vv flag

rclone Yandex log

hello and welcome to the forum,

for sure, rclone mount, run with admin privileges, can run .exe.
i have done that many times

as a test, try to execute a simple .cmd, such as

echo hello world

make sure to use lasest version of winfsp

from the config file, there is
_rclonetray_local_path_map =

perhaps there is an issue with rclonetray?

What I need is running exe files as admin, not rclone

I tried only to see that error (see embedded picture)

can you translate to english?

It tells that there is a network error that cause the exe to not run

  1. run the mount with admin privileges.

  2. list files in z: and run zork.exe with admin privleges.

  3. play the game z:\zork.exe

Aka unable to access file
Even when file and dir perms have been set to 777

The problem is, in order for all users to access the mount, rclone need to be run as a system service
So how to run such service as admin?
My setup is nssm with AppParameters as described in issue (without rclone text)


Then will the mount be accessible from all users?

No, I don't even get that working
I installed the service as my local account as admin, but the error keep appearing

Same when I run as non-admin
If I Run as admin the mount will not appear

This one is a probable solution, however, I want to run the exe from non-admin apps, like explorer

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.