Exclude " *.!qB "

Hello everyone!

I was trying to sync a qbittorrent download folder with my NAS from a local server.
For that reason i wanted to exclude every file with the ending .!qB - which are incomplete files.

I didnt managed to get it to work propably.
It was working in some test actually, but running the same in a cron script was moving the *.!qB files anyhow.

what i tried is

--exclude '*.!qB'
--exclude "*.!qB"
--exclude-from file --> file: *.!qB as well as the both others '*.!qB', "*.!qB"

the problem was the " ! " in the file ending, which is giving me problems :-/

maybe someone knows how to keep those files.

edit: it was not showing the * in the lines with --exclude

rclone touch 'file.!qB'
rclone touch file.ext
rclone ls .
        0 file.!qB
        0 file.ext
rclone ls . --exclude='*.!qB'
        0 file.ext

--exclude=... should be the same as --exclude ... (as i did it)
the consequence was that !qB files where moved anyhow, dont know why, did tests before as well.

That's generally why we ask for a command, a log file as it takes out all the guessing work.

You could be running some old version that doesn't work right.

Whole reason we have a nice help and support template.

well, confusing, as you re-edited your first post, after i had already posted my reply.

in your initial post, you had only

what i tried is
--exclude '.!qB'
--exclude ".!qB"

and if you had tried, it would have worked

rclone ls . --exclude '*.!qB'
        0 file.ext

yes sorry, i thought the problem is on my command.

$ rclone --version
rclone v1.64.0
- os/version: debian 12.2 (64 bit)
- os/kernel: 6.1.0-13-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.1
- go/linking: static
- go/tags: none

i have a log from the command i was running with the given exclude, where i can see that !qB files have been uploaded and deleted afterwards

yes, but i was commenting my edit. btw you edited your post as well

if you do not use the </> format, the forum software will not show the * between the 's and "s

--exclude '*.!qB'

no, it was not working - and i never said that - while actually using it on a lot of files.
but i will check it and figure it out by myself. maybe it is/was a problem that filenames changed while the command was actually running

btw: if you press on my edit and look at the raw format, you can actually see exactly, that i was always writing *.!qB and your edit only shows that you didnt used ' ' before and that you are in a windows environment, dont know if that makes any difference, never used rclone on windows as i am not using windows at all.

i am just a volunteer trying to help you when you did not post the required info include output of rclone version.
in your tittle you use ” *.!qB ” so i thought you might be a windows user.
i posted a windows example.
finally, you posted the output of rclone version, i realized that you are on linux, so as helpful volunteer, i changed the example to linux, to help you.

zero difference. in the end , i shared two working examples, windows and linux.

you are welcome.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.