Example of remote control bwlimit?

The ability of controlling rclone on the fly using --rc sounds fantastic! I assume in this way we can adjust the upload speed dynamically, leaving enough bandwidth for everything else by checking how much % of bandwidth is left.

However I am unable to fully comprehend the instruction at https://rclone.org/rc/ . When I use “rclone rc core/bwlimit rate=1M” on a ubuntu system with rclone copy running as:

/usr/local/bin/rclone copy SOURCE DESTINATION -L -v --tpslimit=4 --tpslimit-burst=1 --transfers=2 --cache-workers=2 --bwlimit=27M --log-file=/***/rclone.log --rc

It returns the following error:

(1:47am)/home/great/bin >rclone rc core/bwlimit rate=1M
“error”: “couldn’t find method “core/bwlimit””,
“input”: {}
2018/04/07 01:47:36 Failed to rc: operation “core/bwlimit” failed: couldn’t find method “core/bwlimit”

When I run “rclone rc”, it doesn’t show the core/bwlimit command, but only the other commands:

/home/great/bin >rclone rc

rc/noop: Echo the input to the output parameters

This echoes the input parameters to the output parameters for testing
purposes. It can be used to check that rclone is still alive and to
check that parameter passing is working properly.

rc/error: This returns an error

This returns an error with the input as part of its error string.
Useful for testing error handling.

rc/list: List all the registered remote control commands

This lists all the registered remote control commands as a JSON map in
the commands response.

Should I configure something else to enable the core/bwlimit control?

Alternatively, I also tried to follow the instruction:

$ rclone rc rc/noop param1=one param2=two
“param1”: “one”,
“param2”: “two”

But couldn’t figure out in the case of core/bwlimit, what’s “param1” and what’s “one”?

Anyone got it working please kindly give an example how to dynamically control bwlimit from the localhost?

Thank you!

Your syntax is exactly right

rclone rc core/bwlimit rate=1M

The only thing I can think of is you are using a version of rclone which doesn’t support core/bwlimit - what version are you using and can you try v1.40 or the latest beta?

Thank you for the feedback! Turned out that I have rclone at both /usr/bin/ and /usr/local/bin/ and only one of them was updated to 1.4 and my script called the other v1.39 rclone. After using the right rclone, it’s working perfectly now. Thank you for the great program!

1 Like