Error was: user: Current not implemented on linux/amd64 even with --config supplied

rclone v1.42
- os/arch: linux/amd64
- go version: go1.10.1


I’m using the script from here: (Scroll to section “Hooking rclone to Proxmox VE backup subsystem”)

Which calls rclone like this: /usr/bin/rclone copy -v --config /root/.config/rclone/rclone.conf $tarfile remote:path

I am however still getting the following error:

INFO: 2018/07/14 02:07:15 ERROR : Couldn't find home directory or read HOME or XDG_CONFIG_HOME environment variables.
INFO: 2018/07/14 02:07:15 ERROR : Defaulting to storing config in current directory.
INFO: 2018/07/14 02:07:15 ERROR : Use --config flag to workaround.
INFO: 2018/07/14 02:07:15 ERROR : Error was: user: Current not implemented on linux/amd64

But rclone still succeeds the upload:

INFO: Transferred:   247.089 MBytes (14.748 MBytes/s)
INFO: Errors:                 0
INFO: Checks:                 0
INFO: Transferred:            1
INFO: Elapsed time:       16.7s

I don’t think it should throw out errors when --config is supplied and it actually succeeds the upload.

I agree with you.

It is hard to fix though as rclone needs to work out the config path in order to set the default for the --config flag, so it can’t tell whether the config flag has been supplied at that moment in time or not!

I guess I could look for --config or --config= in the arguments as a work-around.

Can you please make a new issue on github and I’ll fix it one way or another - thakns!


What do you get if you type:

go version

and does your file path exist?

ls -al /root/.config/rclone/rclone.conf produces?

I’ve fixed this now - it should be in the latest beta :slight_smile: