Error running Rclone native on FireTV2 (rooted)


#1

Hello together,

i tried to get rclone running on FireTV2 rooted … i used the original V1.38 64 Bit Linux ARM binary - everything works fine … did the follwing :

DOS Box :
adb connect 192.168.0.52

adb push rclone /storage/sdcard0
adb push rclone.conf /storage/sdcard0

Adb shell

ADB :
mount -o remount,rw /system

cp /storage/sdcard0/rclone /system/bin
chmod 775 /storage/sdcard0/rclone

cd /storage/sdcard0
mkdir 0.RClone

rclone --config=/storage/sdcard0/rclone.conf mount gdrivecrypt: /storage/sdcard0/0.RClone

It runs ,but after a few seconds following error comes up :

On Google :

Failed to create file system for “gdrivecrypt:”: failed to make remote “gdrive:enc” to wrap: couldn’t read info about Drive: Get https://www.googleapis.com/drive/v2/about?alt=json: Post https://accounts.google.com/o/oauth2/token: dial tcp: lookup accounts.google.com on [::1]:53: read udp [::1]:33331->[::1]:53: read: connection refused

On Amazon :

Failed to create file system for “acdcrypt:”: failed to make remote “ACDF:ENC” to wrap: failed to get endpoints: Get https://drive.amazonaws.com/drive/v1/account/endpoint: Post https://quixotic-module-170120.appspot.com/token: dial tcp: lookup quixotic-module-170120.appspot.com on [::1]:53: read udp [::1]:49834->[::1]:53: read: connection refused

Is it general not possible to run rclone directly without 3rd Party Apps on Android ?

Thanks for advise !

FoGBaV


#2

OK - sorry … i found the right post in the Forum … seems that android binary needs to be compiled manualy because ARM VErsion not working correctly …

Thanks


#3

OK - did the Termux thing to get newest Android binary compiled … now i get :

Fatal error: failed to mount FUSE fs: fusermount: exec: “fusermount”: executable file not found in $PATH

No Fuse on FireTV 2 - no fuse in Termux …

Is there a posibilty to get FUSE on FireTV activted ?Don’t think so - Kernel Modul problem … s*** …8)

Any ideas how to rclone on Android without fuse compiled in Kernel .?


#4

FUSE is required for the rclone mount command.

“FUSE” is “Filesystem in Userspace” and is a way that the kernel can call back into a userspace application to do stuff like “open a file”. The rclone program provides the userspace component. Without FUSE there is no way for the kernel to set up the required hooks.

fusermount is a helper program to tell the kernel FUSE module what to do. You could compile that, yourself, but without the FUSE kernel module then doesn’t really help.

If you don’t use the rclone mount command then you don’t need FUSE. If you want FUSE on your FireTV then you’ll probably need to look at some of the FireTV hacking forums to see if someone there has achieved it.


#5

Both those errors are to do with name service not working.

I think you will either need to rebuild rclone for android or since you have root, adding an /etc/resov.conf may fix it.


#6

As an experiment I build an android binary for rclone using circleci if anyone would like to give it a go!


#7

I managed to get rclone mount working on my Shield TV by installing Entware-ng and using that to install fuse-utils. However, it was not stable at all. I ended up doing the mount on my NAS and pointing my Shield TV to it over SMB.


#8

Was this difficult for you to do? Because i gave this version a go, and it worked brilliantly! I would really really like a version that can ‘serve http’, as this version doesn’t have that…

I actually spent a bit of time trying to get a rclone version that worked under kitkat for an old tv box (ouya) that i had lying around. This one worked, but didn’t have the command i wanted.

Thanks for everything


#9

These are being build continuously by the circleci build process now.

If you look at rclone’s circle CI page: https://circleci.com/gh/ncw/rclone

Click the latest master build, click on the artifacts tab then you can see the artifacts

https://1010-17803236-gh.circle-artifacts.com/0/tmp/rclone.dist/rclone-android-16-arm

You might need to be a member of the project to do that though - the above link should work though.


#10

Thanks! I can’t see the artifacts, but the link does work.

rclone is running great!