Error listing encrypted storage

I must be missing something obvious …

I’m trying to list the contents of a folder that is in an encrypted storage (in Dropbox), with file name encryption and directory name encryption enabled:

filename_encryption = obfuscate
directory_name_encryption = true

And I’m trying to:

rclone ls storage: --crypt-show-mapping

But it returns me the error:

NOTICE: [folder_name_without_crypt]: Encrypts to "194._bjhxrph-igpchu4--gradct_rgxeidvgpupsd"
ERROR : [folder_name_without_crypt]: error listing: directory not found
Failed to ls: directory not found

And [folder_name_without_crypt] has alternating uppercase and lowercase letters in the name.

Can you show (your redacted) config for storage:? That should make it obvious what is going on.

Do you mean the conf file?

type = crypt
remote = Dropbox:backups_Rclone/cripto
filename_encryption = obfuscate
directory_name_encryption = true
password = ioioioio
password2 = ioioioio

Inside this folder (Dropbox:backups_Rclone/cripto) I have:

And inside the “194...” encrypted folder:

And the command is:

rclone ls Dropbox_cripto: --crypt-show-mapping

I did a new test, with a different set of files, and uploaded it to two new storages.

One of them with filename_encryption = standard and another with filename_encryption = obfuscate.

Then I ran the same command above: rclone ls [storage]: --crypt-show-mapping

For the first storage, worked perfectly. For the second, it returned the same error described in the first post.(!)

I’m pretty sure I’m doing something wrong, but I can’t figure out.

I see what is happening now…

I set up a crypt with filename obfuscation pointing at dropbox

$ rclone mkdir obfuscate:folder_name_without_crypt
$ echo "hello" | rclone rcat obfuscate:folder_name_without_crypt/hello
$ rclone ls obfuscate: --crypt-show-mapping2018/03/28 21:21:44 NOTICE: foldeR_name_WiThoUT_cRYpT: Encrypts to "128.pyvnob_xkwo_gsdryed_mbizd"
2018/03/28 21:21:45 NOTICE: foldeR_name_WiThoUT_cRYpT/hello: Encrypts to "128.pyvnob_xkwo_gsdryed_mbizd/20.jgnnq"
        6 foldeR_name_WiThoUT_cRYpT/hello

Underlying looks like

$ rclone ls dropbox:test/obfuscate
       54 128.pyvnob_xkwo_gsdryed_mbizd/20.jgnnq

So what it looks like is that something lowercased the obfuscated name for some reason.

Dropbox is case insensitive but it normally preserves the case of names. I wonder if it doesn’t preserve the case of directories.

$ rclone mkdir dropbox:test/HelloHello
$ rclone lsd dropbox:test
          -1 2018-03-28 21:27:55        -1 hellohello
          -1 2018-03-28 21:27:55        -1 obfuscate

Ah, I see, it is rclone lowercasing the root for some reason.

Can you please make a new issue on github about this and I’ll have a go at fixing it - link to this forum post please!


Ok, but this second test I did only involved lowercase files:

├── pasta1
│   ├── pasta 1.2
│   │   └── teste1~.2.txt
│   └── teste1.txt
├── pasta2
└── teste0.txt

Maybe is related to this old issue?

Dropbox Folder Case Sensitivity Issue #691

The obfuscate method relies on the remote preserving the case… So all lower case may map to things with uppercase stuff in

Hmm, it is possible. However that issue relates to the dropbox v1 api implementation which had all sorts of problems, so I’d rather have a new issue with a reference to that one!

I’ll have to do a bit of digging as to why rclone lowercases the root, and whether rclone can stop doing that without breaking stuff!

Issue #2191 opened.

Thanks Nick, for your attention and support!