Error googleapi: Error 403: User rate limit exceeded., userRateLimitExceeded

What is the problem you are having with rclone?

transfer did not start after listing

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 6.2.0-32-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.1
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vv --fast-list --progress copy /mnt/tank/ハラエティ番組/ GoogleDrive:/ハラエティ番組/

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
scope = drive
team_drive = 
token = XXX
client_id = XXX
client_secret = XXX

type = mega
user = XXX
pass = XXX

type = crypt
remote = Mega:
password = XXX
password2 = XXX

A log from the command that you were trying to run with the -vv flag

I have got the error stated in the subject.

I am using a custom created API key. On the dashboard it shows the usage is 0:

Should I assume rclone has been tweaked for Google Drive limit? Or do I have to tweak it by myself?
Is it really creating too many requests hence hitting the Google limit?


Sounds like you probably didn't configure it to be used, but since you deleted the whole help and support template, we have no idea on your config/version/any error log.

Sorry I have put them back.

Have you added client_id = XXX and client_secret = XXX to rclone.config after creating GoogleDrive remote?

If yes then they are not used. They have to be bound to the token. The easiest way to ensure it is to create this remote from the scratch providing client_id/client_secret in the configuration process.

Then if you still see Error 403: User rate limit exceeded you have to slow down your copy command.

Add for the start --tpslimit 10 --tpslimit-burst 0 flags - increase/decreace --tpslimit to ensure that errors are gone. There is no one best value here and you have to find what works the best for you.

I have went through rclone config to create GoogleDrive:

With the rclone command running, I can see the error count on Google API dashboard kept increasing.
So I believe the API Key is being used.

I have tried switching back to rclone built-in key. Still no transfer speed.

If it is really using up the limit, I wonder if I can confirm it on anywhere from Google webpage?
I may want to try asking Google to raise the limit.

Try something ridiculously slow:

--tpslimit 1 --tpslimit-burst 0

to see if it works.

Still seeing DEBUG : pacer: Rate limited, increasing sleep to 16.033169104s with no transfer speed.

Maybe you used all your quota for this hour/today? I am not 100% sure how Google throttles.

How to check how much quota do I have / used?

@Animosity022 I think you have some Google remotes experience... Any clever ideas here?

1 Like

Realistically, you never run out of Google API as that's rarely the problem unless you are using the overload default rclone one.

Chances are if you are seeing any API hits on the API page, you aren't using the key you made. Best bet is to make a new remote and connect it.

Additionally, Google has daily upload quotas and download quotas. 750GB seems to be the upload and ~10TB seems to be the download. If you hit those, you wait 24 hours and nothing you can do. Google will not raise/alter/change or do a thing for you. Ask away and you'll get denied.

Very likely I have hit the 750 daily upload rate. Is it officially stated by Google, or just by our experience? I have used GSuite several years ago, it seems there was no such limitation.

Thanks. You should have given the answer.

Check Google:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.