Error 403 when using --drive-root-folder-id

What is the problem you are having with rclone?

when I run rclone lsd Backup9: --drive-root-folder-id=XXXXXXXXXXXXXXX, I get the correct output, but when I run rclone copy Backup9: --drive-root-folder-id=XXXXXXXXXXXXXXX "Backup9:\path\", I get the following error: ERROR : Folder/filename.ext: Failed to copy: failed to make directory: googleapi: Error 403: Insufficient permissions for the specified parent., insufficientParentPermissions

Run the command 'rclone version' and share the full output of the command.


Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy Drivename: --drive-root-folder-id=XXXXXXXXXXXXXXX "Drivename:\path\" --drive-server-side-across-configs -v

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret = XXX
scope = drive
token = {"access_token":"ya29.XXX","token_type":"Bearer","refresh_token":"XXX","expiry":"2022-04-07T16:18:48.5270945-04:00"}
team_drive = 0ANXXX
root_folder_id = 

A log from the command with the -vv flag

Paste  log here


  1. please redact/delete the id/secret/token from that config file.
  2. post the full output of rclone version
  3. post a full debug log
  4. --drive-server-side-across-configs that should do nothing, as you are using a single remote for source and dest.

I have done this!

This is because the --drive-root-folder-id is applying to both the source and the destination.


rclone copy "Drivename,root_folder_id=XXXXXXXXXXXXXXX:" "Drivename:\path\" --drive-server-side-across-configs -v

hi, in this case, where the source and dest are the same remote, does that flag do anything?

Hmm, probably not, but it doesn't hurt either.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.