Error 403: The granted scopes do not give access to all of the requested spaces., insufficientScopes

What is the problem you are having with rclone?

I'm new to rclone. I just installed and configured it today.

I tried:

rclone ls my-gmail:

But it returned the next:

Failed to ls: couldn't list directory: googleapi: Error 403: The granted scopes do not give access to all of the requested spaces., insufficientScopes

I tried both: scope = drive.appdata and scope = drive

What is your rclone version (output from rclone version)

rclone v1.55.1

  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.3
  • go/linking: static
  • go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls my-gmail:

The rclone config contents with secrets removed.

[my-gmail]
type = drive
client_id = XXXXXXXXXXXX.XXXXXXXXXXXXXXXXXXXXXX.apps.googleusercontent.com
client_secret = XXXXXXXXXXXXXXXXXXXX
scope = drive.appdata
root_folder_id = appDataFolder
token = {"access_token":"xxxxxxxxxXxXxXxXXxxxxxXXXXXXxxxxXXx...","token_type":"Bearer","refresh_token":"1//xxxxxxxxxxxxxxxxxx,"expiry":"2021-05-24T17:13:49.607602586+02:00"}


A log from the command with the -vv flag

<7>DEBUG : Using config file from "/home/tes/.config/rclone/rclone.conf"
<7>DEBUG : rclone: Version "v1.55.1" starting with parameters ["rclone" "ls" "my-gmail:" "-vv"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Creating backend with remote "my-gmail:"
<7>DEBUG : 4 go routines active
Failed to ls: couldn't list directory: googleapi: Error 403: The granted scopes do not give access to all of the requested spaces., insufficientScopes

Is this actually the word appDataFolder or something else?

Thanks @Animosity022

It is exactly the word "appDataFolder".

I remember that I had to use appDataFolder to solve another issue during installation (something that I found in Google... :man_facepalming: )

After removing this token, and leaving root_folder_id in blank, it's working properly

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.