Error 403: The file limit for this shared drive has been exceeded

Hi there!

I use an seedbox to download tv and movies. Then i use rclone to move tv to an teamdrive and then use serverside move to my gdrive i use for plex.
This is the commands:
rclone move -v --bwlimit 8.5M --max-transfer 740G --drive-stop-on-upload-limit --log-file=/home/xxx/.config/cron/logs/cron-sonarr-xxx-tv-audio.log /home/xxx/data/down/sonarr/move-tv/tv/ xxx:/tv/

and then serverside move:

rclone move --ignore-existing --tpslimit 1 -v -P --log-file=/home/xxx/.config/cron/logs/cron-sonarr-xxx-tv-audio-move.log 'xxx:/tv' gdrive:media/tv/tv --drive-server-side-across-configs --delete-empty-src-dirs

It has been working well for a month with no issues. Suddenly i get this error when trying to move files from my seedbox to teamdrive:
Error 403: The file limit for this shared drive has been exceeded., teamDriveFileLimitExceeded
I have read the limits in teamdrive and i dont have many files and its not that many i try to move. I have empty the trash with:
rclone cleanup remote:

I have tried to copy to another teamdrive and that works. For a while then i get the same error!

Please! Please! Can someone help me!

That means you hit a limit with Google and not much to do other than wait unfortunately.

The limit is 400,000 according to the docs

Is it likely you've got that many files?

What does rclone size remote: say? And if you include the deleted files with rclone size --drive-trashed-only remote:?

Note that you'll need rclone v1.54.0 or later to ensure rclone cleanup works on team drives.

1 Like

rclone size remote says:
Total objects: 28
Total size: 69.812 GBytes (74959712384 Bytes)

rclone size --drive-trashed-only remote says:
Total objects: 394282
Total size: 106.601 GBytes (114461936181 Bytes)

And the version i use is v1.55.1

So i understand that its the trash that makes my rclone commands not to function. But why is the trash not emptied when i run rclone cleanup remote: ??
I havent been able to move anything for several days. I havent had this problem before.

Emptying trash isn't automatic as it depends on how much you have in the trash.

Sounds like you hit a quota unfortunately and nothing to do other than wait.

Ok. But rclone cleanup remote: should empty my trash? Or are there any other command that i can use. Doesnt feel very fun to delete the files manually :wink:

....or is there a way i can delete the files when using server-side thats skips the trash and deletes the files anyway?

You can use:

https://rclone.org/drive/#deleting-files

It does, but it's not automatic. It issues a command to delete the trash and depending on the drive and number of files, you have to wait until Google catches up. Nothing rclone can do here.

Thanks!
I will try using:
--drive-use-trash=false

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.