Erro using flag --include

Hello Guys

Recently I've changed my backups from Onedrive Personal to Onedrive Business and I didn't know that Onedrive Business sum in the quota usage the file versions.

So, I've read in the rclone documentation that I can use the flag " --onedrive-no-versions" to not keep versions.

I've changed my script and included the flag above, but I noticed an error when I use a flag "--include Volume-Diario-*"

I'm running rclone 1.56
rclone copyto /backup onedrive_business:storage1 --include Volume-Diario-*

rclone copyto /backup onedrive_business:storage1 --include Volume-Diario-*
  rclone copyto source:path dest:path [flags]

  -h, --help   help for copyto

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command copyto needs 2 arguments maximum: you provided 21 non flag arguments: ["/backup" "onedrive_business:storage1" "Volume-Diario-0002" "Volume-Diario-0003" "Volume-Diario-0004" "Volume-Diario-0005" "Volume-Diario-0006" "Volume-Diario-0007" "Volume-Diario-0008" "Volume-Diario-0009" "Volume-Diario-0010" "Volume-Diario-0011" "Volume-Diario-0012" "Volume-Diario-0013" "Volume-Diario-0014" "Volume-Diario-0015" "Volume-Diario-0016" "Volume-Diario-0017" "Volume-Diario-0018" "Volume-Diario-0019" "Volume-Diario-0020"]




I tested it with single quotes and it worked.

But the strange thing is that last month it worked fine without single quotes. The script I created a while ago

and you used the exact same value for the include, including the asterisk character?

Yes. I don't know if could be something of SO (Debian 9.13) or rclone

i am sure it is not rclone, as you can see from the error, that bash or whatever runs your rclone command, expanded the * to approx. 20+ items.

rclone can only process whatever command it is given...

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.