Encrypted remote doesn't encrypt anything

What is the problem you are having with rclone?

Encrypted drive doesn't encrypt anything.

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.1
- os/version: slackware 15.0+ (64 bit)
- os/kernel: 5.19.17-Unraid (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.19.3
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -v copy /mnt/user/data/documents/Linux.jpg dropbox:crypt

The rclone config contents with secrets removed.

type = dropbox
token = XXXX
client_id = YYYY
client_secret = ZZZZ

type = crypt
remote = dropbox:/crypt
password = XXXX
password2 = YYYY

A log from the command with the -vv flag

2022/12/06 16:36:53 DEBUG : rclone: Version "v1.60.1" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone/.rclone.conf" "-vv" "copy" "/mnt/user/data/documents/Linux.jpg" "dropbox:crypt"]
2022/12/06 16:36:53 DEBUG : Creating backend with remote "/mnt/user/data/documents/Linux.jpg"
2022/12/06 16:36:53 DEBUG : Using config file from "/boot/config/plugins/rclone/.rclone.conf"
2022/12/06 16:36:53 DEBUG : fs cache: adding new entry for parent of "/mnt/user/data/documents/Linux.jpg", "/mnt/user/data/documents"
2022/12/06 16:36:53 DEBUG : Creating backend with remote "dropbox:crypt"
2022/12/06 16:36:54 DEBUG : Linux.jpg: Need to transfer - File not found at Destination
2022/12/06 16:36:55 DEBUG : Linux.jpg: Uploading chunk 1/1
2022/12/06 16:36:56 DEBUG : Linux.jpg: Uploading chunk 2/1
2022/12/06 16:36:57 DEBUG : Dropbox root 'crypt': Adding "/crypt/Linux.jpg" to batch
2022/12/06 16:36:58 DEBUG : Dropbox root 'crypt': Batch idle for 500ms so committing
2022/12/06 16:36:58 DEBUG : Dropbox root 'crypt': Committing sync batch length 1 starting with: /crypt/Linux.jpg
2022/12/06 16:36:58 DEBUG : Dropbox root 'crypt': Committed sync batch length 1 starting with: /crypt/Linux.jpg
2022/12/06 16:36:58 DEBUG : Linux.jpg: dropbox = f0ad10cbfe22528ed991e1adbbab0bf4c2d1d8cae3ef10f74a314423400f9f4a OK
2022/12/06 16:36:58 INFO  : Linux.jpg: Copied (new)
2022/12/06 16:36:58 INFO  :
Transferred:      118.691 KiB / 118.691 KiB, 100%, 29.646 KiB/s, ETA 0s
Transferred:            1 / 1, 100%
Elapsed time:         4.9s

2022/12/06 16:36:58 DEBUG : 10 go routines active
2022/12/06 16:36:58 INFO  : Dropbox root 'crypt': Committing uploads - please wait...

I've tried to unmount the dirrectory with

fusermount -u /mnt/disks/crypt

creating it again with:

mkdir -p /mnt/disks/crypt


rclone mount --max-read-ahead 1024k --allow-other dropbox:crypt /mnt/disks/crypt &

I've also tried setting it up again with rclone config.
I've mainly followed this guide since I started having trouble:

Along with Rclone crypt documentations:

But no matter what I do, it doesn't encrypt anything.
I check it by logging into Dropbox on their website and checking if it's jibberish or not.
The file is there, but it's not encrypted.

I'm sure I'm missing something, I just can't figure it out, and I'm running out of ideas and going in circles here.
Can anyone see where the problem is, or can point me in the right direction?

You want to the crypt: remote for it to crypt.

I knew it was something simple somewhere, I just couldn't figure it out.
I'm such a moron.....

I'll try it right away and let you know if it worked or not.

Just to be clear.
The cryptfor me, should be this:


No, it should be crypt: as I noted above.

Just try a simple rclone copy onefile crypt:

rclone ls crypt:

and validate you see your file.

But that doesn't point anywhere in the Dropbox drive?

Your config there does.

You are pointing the crypt: remote to the previous dropbox: remote.

Trust me, give a test..

omg.............. My ill brain can't think.
I'm so sorry for being so dumb. You are 100 % correct.
It works now, thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.