"/" encoded to "‛/" when `--local-encoding None` was added

What is the problem you are having with rclone?

''/" in file-name or folder-name has been encoded to "‛/" although --local-encoding None args was added during sync

What is your rclone version (output from rclone version)

rclone v1.54.0

  • os/arch: linux/amd64
  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

NAME="Ubuntu"
VERSION="20.04.1 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.1 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="Data privacy | Ubuntu"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal

Which cloud storage system are you using? (eg Google Drive)

from: local
to: mega

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync voices/ mega:voices -P --bwlimit 40M --local-encoding None --dry-run

The rclone config contents with secrets removed.

[mega]
type = mega
user = REMOVED
pass = REMOVED

A log from the command with the -vv flag

2021-08-07 17:13:01 NOTICE: voice/按照RJ号命名的作品/RJ265627/音声/環境音無し‛/SE無し/6.エピローグ.mp3: Skipped copy as --dry-run is set (size 4.488M)

# when --dry-run was removed, it becames to 
voice/按照RJ号命名的作品/RJ265627/音声/環境音無し‛/SE無し/6.エピローグ.mp3: error reading source directory: directory not found

what's more

if you have a file already named "‛/", then it will be encoded to "‛‛‛/"