Empty token found

What is the problem you are having with rclone?

: failed to configure dropbox: empty token found - please run "rclone config reconnect dbx:"

Not sure what changed but there is now a refresh token as well.

Run the command 'rclone version' and share the full output of the command.

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads

root@caf1439ffd91:/workspace/training_gr4ph1cw/model# rclone selfupdate
2024/04/05 22:22:21 NOTICE: Successfully updated rclone from version v1.58.1 to version v1.66.0

Which cloud storage system are you using? (eg Google Drive)

dropbox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

`rclone copy /workspace/training_gr4ph1cw/model

rclone copy /workspace/training_gr4ph1cw/model dbx:/studio/ai/libs/SD/2loras/2styles/gr4ph1cwbw_v2

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

not sure how to do this

A log from the command that you were trying to run with the -vv flag

root@caf1439ffd91:/workspace/training_gr4ph1cw/model# rclone copy /workspace/training_gr4ph1cw/model dbx:/studio/ai/libs/SD/2loras/2styles/gr4ph1cwbw_v2 -vv
2024/04/05 22:26:45 DEBUG : rclone: Version "v1.66.0" starting with parameters ["rclone" "copy" "/workspace/training_gr4ph1cw/model" "dbx:/studio/ai/libs/SD/2loras/2styles/gr4ph1cwbw_v2" "-vv"]
2024/04/05 22:26:45 DEBUG : Creating backend with remote "/workspace/training_gr4ph1cw/model"
2024/04/05 22:26:45 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2024/04/05 22:26:45 DEBUG : Creating backend with remote "dbx:/studio/ai/libs/SD/2loras/2styles/gr4ph1cwbw_v2"
2024/04/05 22:26:45 Failed to create file system for "dbx:/studio/ai/libs/SD/2loras/2styles/gr4ph1cwbw_v2": failed to configure dropbox: empty token found - please run "rclone config reconnect dbx:"

I did search this issue which has never happened to me. And this refresh token is news to me. havent seen it in the last year

ANyone could help me out here?

hi,
sometimes going from old versions of rclone to latest, issues can crop up.
so can run rclone config reconnect dbx:

rclone config redacted dbx:


not sure, maybe this change in v1.59.0 has something to do with your issue
Migrate from deprecated api

for example, in v1.55.1, a similar issue might have occured with dropbox remotes,
requiring rclone config reconnect needed
Fix About after scopes changes - rclone config reconnect needed

hopefully @Animosity022 knows?

Actually happened before i ran β€˜rclone selfupdate’

Also, i also get empty token when I use the refresh token with the command

β€˜β€™β€™
rclone config redacted dbx:
β€˜β€™β€™

I would try to create this remote from scratch. I have seen tokens created with older rclone version breaking things later.

It is easier to create all new remote than trying to figure out what is broken.

1 Like

I've of course tried new connections from different runpod headless machines. This is system wide

the output of the config is different from what it was before. i didnt get this refresh token option before:

Paste the following into your remote machine --->
{"access_token":"sl.ByzUwIaJ1U3xvet-k7P-To7v72V3YOVqLv_Cg2K3wZpj8kRVOO4dArZcDc9sq4_uZu8RoAjMCMiaAxPiW-RvcUUvp6YBvQGaJS6_eVL1ulQZgWZUUFpMDHRF4lg_k9UihgpGjfmmZlvrbNw","token_type":"bearer","refresh_token":"dzyoD_hU8KAAAAAAAAAAAZRdiTnMQxfMYoTFC5D5XI3yTlIzMOt_58vplbseJr7S","expiry":"2024-04-06T03:31:46.108385635+02:00"}

(this is an obsolete token of course)

Not offhand. Dropbox has always had a refresh as part of the token to my memory. That was a very old version though and no config is listed so it's tough to guess without seeing it.

Solved. I wasnt selfupdating and copying the code after rclone authorize "dropbox"

thanks for your invaluable support

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.