Elapsed Time seems inaccurate

What is the problem you are having with rclone?

I'm having problems evaluating the "Elapsed time" that rclone outputs when uploading files. While the process itself takes e.g. about 30-35 seconds, rclone says that Elapsed time is only about 4.5s.

What is your rclone version (output from rclone version)

The server runs rclone v1.51.0. I already checked GitHub issues and I saw that 1.51 shouldn't have that issue anymore.

Which OS you are using and how many bits (eg Windows 7, 64 bit)

centOS/RHEL (exact version can be provided later if needed)

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run

rclone \
--s3-force-path-style \
--s3-chunk-size 10M \
--s3-upload-cutoff 10M \
--s3-upload-concurrency 10 \
--s3-disable-checksum \
sync \
mydestination:media \
--stats 5000ms \
--contimeout=10m \
--retries 4 \
--multi-thread-cutoff 10M \
--multi-thread-streams 10 \
--no-gzip-encoding \
--ignore-size \
--ignore-checksum \
--cache-db-purge \
--transfers 30 \
--checkers 30 \
--tpslimit 300.0 \
--progress \
--filter "+ANONYMIZED" \
--filter "-*" 

The rclone config contents with secrets removed.

A standard config for a MinIO host, I guess unneccessary for this problem.


Sorry I can't provide textual output at the moment, this is the only thing our dev gave us.

You have an old version as there have been many fixes to the stat packages, please update and try again.

1 Like

This was fixed in v1.53.0 by this commit so you will need at least that version.

1 Like

Thank you folks, I'll forward that to my colleague and reach out to you if the issue should persist in any way! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.