Dropbox is giving me path/no_write_permission

What is the problem you are having with rclone?

2023/02/19 12:08:06 ERROR : Dropbox root 'tmp/ads': sync batch commit: failed to commit batch length 1: batch had 1 errors: last error: path/no_write_permission2023/02/19 12:08:06 ERROR : 11-13-11-30.mp4: Failed to copy: upload failed: batch upload failed: path/no_write_permission

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.0-beta.6735.d4d7a6a55

  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-143-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

 rclone -L -vv --stats 10s --ignore-existing copy . d:/tmp/ads

The rclone config contents with secrets removed.

type = dropbox
app_key =
app_secret =
token = {"access_token":"xxxx,"token_type":"bearer","refresh_token":"xxx","expiry":"2023-02-19T15:22:41.042692645-08:00"}
client_id = xxxxx
client_secret = xxxxx

A log from the command with the -vv flag


Ok so, I've been using this method for ages but haven't for a few months, went back, started getting permission errors.

Things I've tried:

  1. Refreshing the dropbox token w/ rclone config
  2. Updating rclone to latest stable and then latest beta
  3. Creating a new API app in Dropbox and replacing the client_id and client_secret

I even used:

rclone mount -v --max-read-ahead 1024k --allow-other d: /mnt/dropbox

And was able to write to the folders fine using the fuse mount, but its so much slower than rclone copy...

Any ideas?

With the client ID/secret, make sure you are reconnecting it and the write permissions are checked:

Yup, they are, otherwise I wouldnt be able to write via the mount command fine but here's the permissions:

Reason for running the latest beta?

but your copy has a drive letter?

What OS are you running?

I'm on the latest beta because thats part of the steps it says when you submit a problem, update to latest stable and then goto beta to see if it resolves your issue. I was original on 1.57, then went to 1.61 and now am on 1.62. Same experience on all 3. 1.57 formerly worked a few months ago, last time I tried it.

I named my dropbox share in rclone 'd', as you can see in the rclone.conf I pasted above that, so its not a drive letter.
I'm copying from the current working directory (which is what I use the . for) under /tmp/ads in dropbox.

I am running ubuntu 18.04 (I know this box really needs to be updated) but I have the same problem with the same config on 22.04 FWIW.

Appreciate the responses!

Where do you see that? Please let me know.

Oops. Missed that, I see it now. Thanks.

Did you try to get a new token if you changed out the client ID/secret? Might try to make a new config to be sure.

Unfortunately I did, no diff:

Can you try without the --ignore-existing? I wonder if an existing file is causing a conflict?

Note that the dropbox backend is sensitive to the leading / here d:/tmp/ads is different to d:tmp/ads. The /tmp one refers to a shared folder called tmp where as the other refers to a folder called tmp in your home.

this was it!! thank you so much.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.