Dropbox error when trying to copy or sync

I have used this before on my Linux machine. But now I have a Chromebook and I’m running the Crostini Linux Beta (Debian Stretch) and it worked at one time. But now I am getting this:

2019/01/24 07:51:36 rclone: Version “v1.35-DEV” starting with parameters [“rclone” “copy” “crostinidocs/foo2019.txt” “dropbox:foodocs” “-v”]

And then this error:

2019/01/24 07:51:37 Attempt 1/3 failed with 1 errors and: v1_retired

You’ll need to upgrade rclone to a version with v2 API support. 1.35 only supports the dropbox v1 API which has been retired.

Find a new version here the latest release.

Thanks that worked. But now I’m having a problem adding box. I get this error:

This site can’t be reached penguin.linux.test refused to connect.
Search Google for penguin linux test 53682 auth

I get this error with both auto/manual config.

Not sure what is causing that error. What is the site penguin.linux.test ?

Can you cut and paste the config session?

Box App Client Id.
Leave blank normally.
Enter a string value. Press Enter for the default ("").
Box App Client Secret
Leave blank normally.
Enter a string value. Press Enter for the default ("").
Edit advanced config? (y/n)
y) Yes
n) No
y/n> n
Remote config
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> n
    For this to work, you will need rclone available on a machine that has a web browser available.
    Execute the following on your machine:
    rclone authorize “box”
    Then paste the result below:

Can you take a look at this solution:


UPDATE. I used this solution and it worked. I guess this is a Crostini Linux container issue.

Ah yes, that makes sense. Rclone runs a web server to read the response from the box and it looks like the connection isn’t forwared from the container normally.

You could also have use the techniques here: https://rclone.org/remote_setup/